Can't log in since Sunday, 2/25/24

Same issue for me with the Android app. Since Sunday, it stopped fetching feeds. After logging out, I can’t log in anymore.

App version 13.1.2 on Android 8 over WiFi.

1 Like

@samuelclay Anything change on the SSL side of things with the move? Maybe we’re hitting an issue with mismatched algorithms/versions supported?

Edit: Looks like Android didn’t support TLS 1.3 until version 10, and dwww supported 1.2 and 1.3 while www only does 1.3 right now. That could explain why @nelas and I are having problems on Android 8.

1 Like

Can you upgrade to Android v8.1, which should support TLS 1.3? Supporting TLS 1.2 would lower NewsBlur’s SSL rating: SSL Server Test: (Powered by Qualys SSL Labs)

I’m afraid not, my devices are on the latest official releases. Unfortunately some are just EOL and as a result SOL. :wink:


@samuelclay I’m not too familiar with Android dev but it looks like the app could try using Google Play Services to support older devices.

I also have the same problem on Android 7.0, and there are no android updates available for my phone.
When I set a custom server it works again with:
But I saw in the other thread apparently that address is going away soon :slightly_frowning_face:

1 Like

a rating? really?

i feel like i need to link goodhart’s law here.

Especially true when you compare the www results to the dwww ones.

Ok, I just enabled TLS 1.2. Let me know how that works.

1 Like

yes, that works.

side note: switching servers resets all my settings every time. i’d think people would want to keep the same display options

On iOS/Android? Yeah, you really shouldn’t be setting a custom domain unless you want to lose everything. I don’t recommend doing it.

Yes! I am able to log in on my tablet now. Thank you so much!

Thanks! It works now for me as well.

So using custom server dwww resolved the issue i was having on Newsblur crashing/closing (which I created a separate post about).
It still crashes though if I don’t use custom server.
Android 7.0

@andrei Know why Android 7.0 would crash on www but not dwww? I’m going to be taking dwww down soon, so we need to make sure everybody’s covered.

@samuelclay I tested both www and dwww on a Android 7.0 emulator and everything loaded.
@Turban1894 I checked for crashes for Android version 7.0 but none were reported. When you say it’s crashing/closing do you see the “Android is not responding” or “Newsblur has stopped” message?

FWIW Android 7.0 supports TLS 1.2 Android 7.0 Behavior Changes  |  Android Developers

@ntrel Do you still have issues on Android 7.0?

As soon as I would click login, it literally would close instantaneously and return to my tablet’s homescreen. No messages, errors, popups, toasts, etc.

I vaguely recall it sitting doing nothing on first attempt after fresh install, cache clear, etc for maybe 5-15 seconds and then closing w/ again no message but ya pretty much thereafter its the same thing no matter what I tried until I changed to the dwww custom server. Then it was back to normal again.

@Turban1894 Without any hints is gonna be tough. Would you be willing to install a custom build to see if we can catch the crash and its message? I can put together one tomorrow

Sorry I missed the notification. Yes it works now with the default server, thanks so much!

1 Like