Can't log in since Sunday, 2/25/24

Hello Samuel,

Beginning yesterday, 2/25/24, my NewsBlur app on Android no longer gets new stories.

I tried logging out and back in to remedy the problem, but now I can’t log in. After putting in my credentials, the screen spins at “Logging in…” and “Retrieving feeds…” for a few seconds before exiting back to the login screen with a message stating “There was problem logging in to NewsBlur.”

This happens whether I am on Wi-Fi or mobile data. I have restarted the phone several times. I have tried reinstalling the app. My account credentials work fine when using the Newsblur website on my phone or desktop.

Please advise. Thank you for all the work you put in to your platform.



I am having the same problem. Logged in fine on my computer and phone, but my Fire tablet will not log me in no matter what I do. Glad to know I’m not alone!

1 Like

Hmm, this is a difficult one because both the old server ( and new server ( are both reachable from clients who are having trouble reaching

@andrei Can you take a look at this and see if you can replicate the issue on any of your android devices?

@samuelclay I can replicate some of this on mobile data but WiFi works just fine. While using mobile data I get successful 200 code responses to the network requests but they take 30-40 seconds each.

Fascinating! Can you tell me the IP that is resolving to on mobile data?

Additionally, a traceroute would be great.

Facing same issue on both WIFI and mobile data. Tried to change password through website but it didn’t help.

1 Like

Same issue for me with the Android app. Since Sunday, it stopped fetching feeds. After logging out, I can’t log in anymore.

App version 13.1.2 on Android 8 over WiFi.

1 Like

@samuelclay Anything change on the SSL side of things with the move? Maybe we’re hitting an issue with mismatched algorithms/versions supported?

Edit: Looks like Android didn’t support TLS 1.3 until version 10, and dwww supported 1.2 and 1.3 while www only does 1.3 right now. That could explain why @nelas and I are having problems on Android 8.

1 Like

Can you upgrade to Android v8.1, which should support TLS 1.3? Supporting TLS 1.2 would lower NewsBlur’s SSL rating: SSL Server Test: (Powered by Qualys SSL Labs)

I’m afraid not, my devices are on the latest official releases. Unfortunately some are just EOL and as a result SOL. :wink:


@samuelclay I’m not too familiar with Android dev but it looks like the app could try using Google Play Services to support older devices.

I also have the same problem on Android 7.0, and there are no android updates available for my phone.
When I set a custom server it works again with:
But I saw in the other thread apparently that address is going away soon :slightly_frowning_face:

1 Like

a rating? really?

i feel like i need to link goodhart’s law here.

Especially true when you compare the www results to the dwww ones.

Ok, I just enabled TLS 1.2. Let me know how that works.

1 Like

yes, that works.

side note: switching servers resets all my settings every time. i’d think people would want to keep the same display options

On iOS/Android? Yeah, you really shouldn’t be setting a custom domain unless you want to lose everything. I don’t recommend doing it.

Yes! I am able to log in on my tablet now. Thank you so much!

Thanks! It works now for me as well.