Many sites unable to load since 2/25/24

Starting sometime after 22:15 pst on the 25th a significant number of my feeds broke and won’t repair/reload through the “fix a misbehaving site” steps. I’ve tried it for all listed below. I’ve also tried reading the sites, logging out and back into my account. This behavior is across all devices, the web version and iOS app. Any suggestions would be appreciated. Thanks

1 Like

I also have a couple that are newly-broken in Newsblur:

There was a server update around that date: Can't log in since Sunday, 2/25/24

Do you still have issues loading the feeds?

Starting 2 weeks ago, I cannot get posts from

Please help me.
Robbie White

Yes, I’m aware of the update and assume the difficulties are related. Feeds are still unavailable through Newsblur.


NewsBlur cannot read
Looks normal when using curl to inspect.

Looks fine on my local machine, and it’s showing 403’s on the web, which means they are blocking NewsBlur. You should email them this template:

Hi, I use, an RSS reader, and your RSS feed stopped working on February 24th. NewsBlur just changed hosting providers and now has a different set of IPs. NewsBlur’s IPs are being blocked (HTTP 403). I’d like to request that they are unblocked. Here is a handy list of IP addresses that NewsBlur uses:

Thanks for the template. I’ve sent notices to all of the offending sites and hoping to remain a premium subscriber. However, If they don’t make the requested changes (which they haven’t to date) does that mean that NewsBlur will no longer support these sites?

I’m working on it. It’s a Cloudflare issue. Try contacting Cloudflare and let them know. If enough people complain to Cloudflare they might whitelist newsblur. They’ve done it before but my contacts there are ghosting me.


I started getting this error message a couple of days ago. Is it related or something different? This is from a laptop using Firefox browser.

Also getting this message when the site is google. This is from a laptop using Firefox browser.

Same here with
I need to go into the All view button bottom left, then select the feed itself, and then select Insta-fetch Stories.
Then I can go back to the Unread view to read them with the rest of my feeds.

I’m having a similar problem with

I’ll try emailing CloudFare and CC’ing the publisher. I doubt this local reporter has the expertise or time to figure out what’s going on here.

Is there a way to confirm that cloudfare is responsible for a particular site?

So the Error 403 seems to be coming from Cloudflare?

I’m also having this issue with

The solution posted by rpokane here does not resolve the issue.

@samuelclay, sorry to tag you, but is your recommendation still to complain to Cloudflare using the template you provided here?

For free users (which I would be since I cannot get anywhere on their support website without making an account), it looks like the only options available are to post on their community forums or in their discord channel.

Seems to be the same issue for The Truth About Cars