Marking as read/unread

The items I try to mark as unread don’t stay marked that way, and the items I try to mark as read keep popping up as unread. What’s going on?


I’m seeing similar behaviour. This is what I have observed:

  1. Using Shift-A or the button to mark all as read does not appear to be working. The stories go from bold to normal, but the unread count in the left pane does not change, and if I click on that feed again, I see the same set of stories (in bold for unread again.)

  2. Individual stories that I actually read get permanently marked as read. The unread count in the left pane decrements, and if I click on the feed again those stories are no longer visible (when only showing unread stories.)

Possibly related:

  1. The “Counting is difficult” panel never goes away. The progress bar goes up to 100%, but the panel never fades out like normal.

Tried with two different browsers, Firefox and Chrome, with the same behaviour.

Newsblur not really usable with this problem.

I’m on it. Was part of a faulty deploy that I made as a result of being sick for the past three days. Work that should’ve been on a branch ended up in production. Reverting back now.

Fixed. I’m terribly sorry about this one. Should work fine now.

1 Like

Thank you Samuel! Hope you feel better soon!

This problem seems to be coming and going a bit. Seemed to be fixed for one browsing session, but then come back a bit later and it is doing it again.

Tried clearing cache, logging out/in and restarting browser to no effect.

This problem is definitely still there. Help!

Ok, please be specific then. What platform are you using and how are you verifying that this is an issue?

Samuel–Firefox 28.0 on MacOS. Symptoms are similar to what ecognito posted. “Counting is difficult” bar never goes away, and trying to mark all articles read doesn’t quite work (for example, if I double click on the number of unread articles, newsblur doesn’t erase the number as expected, although it seems to mark all the articles read)

Clearing cookies and cache doesn’t help.

This may be specific to Firefox as it doesn’t happen on Chrome.

I’m having some database issues that are definitely affecting this. It should complete in about an hour. But I’m also heading to sleep (I run this maintenance every couple months), so the issue should clear up soon, but I’ll check on it in the morning.

If you want to see system status, take a look at those graphs on the dashboard. The average load time graph doesn’t look too healthy today, does it? I try to keep load times around 100ms (.1 sec), and they’re all over the place now.

Still experiencing issues reported above. Chrome 33, Win7. Mark older stories read not working either.

Also seeing the same issue.

Same here. Using Chrome 33.

Figured it out. Turns out yesterdays DB maintenance caused a bunch of app servers to go into an in-between state where they kept failing. Fixed it but I need to investigate how to prevent it from happening again.

Confirming that this fix worked for me. Thank you!

Samuel–still broken for me. Same symptoms as I described before.

I’m still seeing the same issue, but only on Chrome 33.0.1750.154 m. Firefox 28.0 seems to work fine.

I suggest starting a new thread describing the issue, since this thread has been fixed.

Not fixed for me … same as above … marking “All Read” for a feed un-bolds stories in the title summary area, but does not set the count of unread stories to zero in the left hand pane. If I navigate to another feed, then back to the first, all the stories are bold again.

The problem is intermittent. Sometimes it happens, other times everything seems to work OK, then back to the problem.

I’m running Firefox 27.0.1 on Windows 7 Pro SP1 64 bit

I’m also still seeing the problem intermittently. Firefox 28 and Chrome on Linux.

Perhaps not all the servers got the fix applied?