Items marked "read" ARE NOT read -- when will we get a fix?

Tom, try reloading right now. I just deployed and want to ensure that it wasn’t the result of a bad deploy.

I’m having this intermittently. Sometimes, when I load the page, I get a message on the bottom left corner of my screen which says “counting takes a long time” or something similar, and then marking as read doesn’t work. Then I might hit F5 and that message won’t appear, and then it will work.

What goes wrong is that I click on a feed, usually in List view, I spend some time in there, and then click on the arrow at the left side of the feed’s name in the list and select “Mark as read”. Then the unread count doesn’t refresh, and clicking on that feed again doesn’t make the feeds show as read.

After a few more unread feeds show up for me, I can take screenshots of my developer console.


I stopped Firefox and restarted it, logged into Newsblur and checked:

Sorry amigo, no change.

BTW - I don’t *always* see the “counting is hard” box, but when I do it will always fail to mark all as read.

I just tried this on some feeds with only one unread item (because I didn’t have any with more items). I was having the “counting is hard” box so I thought it wouldn’t work. I had the exact same symptoms as before, except this time they automagically got marked as read after a few seconds of staying unread! Then I tried another feed … waited more than a few seconds, nothing happened. The screenshot of that other feed is attached (I accidentally closed the first developer tools window, the one where they got marked as read later on, before I could save it)

I’ve got the same or a similar issue and it doesn’t matter which browser I use. It does the same thing in both Chrome and Firefox but it’s not consistent. Sometime reopening the tab fixes it and sometimes it doesn’t. I try to check that a folder is read and it still shows as unread. If I try to do it by site, same thing. It really is getting extremely annoying and needs to be fixed. I’m thinking of switching readers. I don’t mind paying for a reader that works but I have a problem with paying for a reader that doesn’t.

I’m having the same problem. The checkbox at the top doesn’t work. The list of stories goes grey but the folder count remains and when refreshed the stories come back.
I can mark the stories as read manually but marking 25 plus stories individually is a pain.
Another annoyance now is sometimes my feeds aren’t being fetched, only when I refresh the page.
I’m using Win 8.1 and Firefox 28.

I think I’ve tracked it down, but it’s bizarre that this hasn’t been a problem for ages. It looks like a race condition caused by loading pages of a feed while marking it as read. So the List view would cause this to come up quit ea bit, because it’s always loading pages.

If you mark as read after the List view stops populating, I bet it always works. Are you marking a feed read before it has a chance to load? I’ll see what I can do about fixing it, but there’s nothing new here.

For me it happens even with just 5 items in the view…

Nope. I waited for it to load the initial items (looked and scrollbar and requests in console) before clicking mark all as read. Makes no difference.

I can even predict when loading Newsblur if it’ll work or not, no need to even select a site. As noted above, several distinct differences seen between when it works and when it doesn’t. “TypeError: this.transport is undefined”, no regular requests to / and the “Counting is difficult” thing.

@Hampus, confirmed.
For me the issue appeared after Firefox was updated to 28. My be it’ll help to resolve the problem.

Nah, it’s not Firefox. Issues occurs in Chrome as well.

I have to agree with Hampus. There is no difference in my experience even after waiting for everything to load.

Ditto on the “Counting is difficult” box. If it’s there, then mark all as read won’t work on a single feed or a folder … and it doesn’t matter if there are 40 items or just one.

Keep trying though. I’d really like to see this fixed.

For what it’s worth, this is probably a browser setting/add-on problem. I had the same thing happening to me even after the developer said it was fixed. Using google chrome with a bunch of addons including adblock/disconnect/ghostery. When I switched to an incognito window, mark all read, as well as save/unsave worked again.

Currently having this issue in Firefox with plenty of addons, Chrome with just a few addons and IE with default settings.

I tried IE10 with default and it worked fine for me. Weird.

Interesting! I just tried with Firefox 27.0.1 (Win7) and had the issue. Switched to a Private Window, logged on to Newsblur, and had no issue.

It’s a bit intermittent. I just opened a private window and logged in, no issue. Reloaded, no issue. Reloaded again and there we go, broken.

The Newsblur tab I’ve got open in Firefox at the moment works fine as well but it took me several reloads to get it to that state.


Just tried things again after being away for a couple of hours.

When I first cranked up Firefox and logged into Newsblur, for about 3 to 4 minutes, everything worked well. No errors when marking a feed as read; no error when opening an item (unread count decremented correctly); etc.

After about 4 to 5 minutes, we are back to totally screwed up on marking as read.

Ditto for opening Newsblur in a Private Window (Firefox).

Just an observation, but there seems to be a correlation between time logged into Newsblur and the onset of error.

I’ve been having this issue for a few days in the browser version of Newsblur on Firefox Nightly. Marking entire feeds or categories as read doesn’t work, they will revert to unread upon a refresh. Also not working is deleting a feed from my feed list, it just comes back when I refresh.

What DOES work is clicking on a news story in the list individually, that will mark it as read for good. Also, marking entire feeds as read in the newsblur android app still seems to work.

Same problem for a few days now on Firefox.

Individual posts are marked as read without issue.

But using “Mark as read” feed option, button or shortcut causes all the post titles to become unemphasised, so they look read, but the unread count in the sidebar remans unchanged, as per the screenshots desert fox posted. Then on refresh the stories are still unread.