Items marked "read" ARE NOT read -- when will we get a fix?

This is now officially irritating. I am a programmer. I can sympathize. But you have let this problem go on for too long.

When will we get a fix?

Thanks.

16 Likes

Samuel’s been sick, as he’s posted on several threads. He’s made a couple of attempts which seem to fix the problems for him. Some more specific reproduction instructions on what you are doing that causes the read articles to return to unread might help.

For what it’s worth, I have not seen this problem at *all*.

I haven’t been able to reproduce it at all, so I’m trying to figure out what the difference is. Please include a thorough way to reproduce the issue so that I can track it down. All of my systems look fine and my stats are showing other folks are marking stories as read using the web app.

I think you guys are not trying (" I have not seen this problem at *all*) very hard to duplicate the problem and find a fix.

Capture01.jpg – notice that in this image, new feed “Reuters: World News” has 40 “unread” items and the Icon to mark all items as read is active

Capture02.jpg – in this image, I have marked all items in “Reuters: World News” as read, but the sidebar still shows 40 items as “unread”. The active pane shows all 40 items marked as “read” and the icon to mark all items as read has disappeared.

Capture03.jpg – in this image, I have moved focus to another news feed. The feed for “Reuters: World News” still shows 40 UNREAD items in the sidebar.

Capture04.jpg – in this image, I have re-focussed on “Reuters: World News”, and we see that the same items that were marked as read have now re-appeared as “not read”, exactly like the list in capture01.jpg.

You need to work with your test bench PC’s to duplicate this asap and find a fix. Create a new virtual machine on one of your dev PC’s and install Firefox from scratch. Use my log-in on your virtual machine if you wish.

With all the recent posts here about this problem it is obviously a real problem.

If you can’t duplicate it, then your test machines are not set up like real world machines. I will tell you (in a private email) exactly how my box here is set up if that will help you.

Tom, can you open your developer console and see if an AJAX request was sent? From the sounds of it, you should be capable of showing a screenshot of your console.

Tom — I am just a user of NewsBlur (though I have contributed some code to the NewsBlur iOS app, I am not responsible for it). I was simply trying to provide some background that this may not be so easy to reproduce as you may have thought.

I realize it’s almost certainly a very frustrating and annoying issue to have happen to you, and I hope that Samuel is able to reproduce it soon. Sorry if I seemed to trivialize your problem; that was not my intent.

@Nicholas – no problem, and thanks for the reply.

I’ve been having this issue intermittently and it sometimes goes away by Ctrl+F5, sometimes it doesn’t.

@Samuel – some captures of the Firebug console. If you get better info from the regular console, I can do some grabs on that as well.

These images are in chronological order over about a 5 minute interval …

Let me know what else might help you fix the problem.

Tom, I don’t see any mark_story_hashes_as_read calls. Were you marking stories as read during this time?

@Samuel – in case it is helpful: Capture10.jpg shows console after the *first* successful “mark all as read” in three days.

I notice a transmit to mark as read (https://www.newsblur.com/reader/mark_…) and a transmit to clear count (https://www.newsblur.com/reader/feed_…) … both of which appear successful.

I’ve been having this issues intermittently as well. Sometimes a page refresh fixes it but far from reliably.

Since you asked had a look in Firefox’s console after I pressed mark all as unread. Mark all as unread didn’t work, nothing happened in the console. After refreshing the page many times, marking as unread finally worked. When it worked I could see two POST requests made, one to “http://newsblur.com/reader/mark_feed_…” and one to “http://newsblur.com/reader/feed_unrea…”.

I also noticed that when it works I see requests to “http://newsblur.com/socket.io/1/xhr-p……” or “http://newsblur.com/socket.io/1/jsonp……” every 20 seconds or so. When mark as unread doesn’t work I also do not see any of these requests.

This error “TypeError: this.transport is undefined common.js:753” also seem to be present every time I reload the page and mark all as read doesn’t end up working. When it does work that error is no present.

Hope maybe some of that is useful.

This problem is hit and miss for me. Sometimes, clicking the Mark as Read button elicits the call you see below. Other times, it does absolutely nothing, i.e. no mark_feed_as_read call is made.

I just tried the same in firebug and when clicking on “mark as read” there are no calls made.

@Samuel

"Tom, I don’t see any mark_story_hashes_as_read calls. Were you marking stories as read during this time? "

No, not marking individual stories as read. Opening up a story marks it as read and decrements the unread stories count on the sidebar. I don’t usually double-click or similar on individual items. Either I read it or skip it based on the headline.

Hold on, there are two issues being conflated here. Marking individual stories as read vs. marking the entire feed as read. Please be specific when talking about these two. How exactly are you marking either stories or feeds as read? Are you hitting the checkmark button at top and it’s not updating the unread count on the feed list? Because that’s what I’m hearing, but I want to make sure that individual stories being opened (and implicitly marked as read) are being marked as read correctly.

In my case, it’s marking the entire feed as read that’s not working - both by hitting the checkmark and using Shift + A.

@Samuel -

I think my posts have been pretty clear, but just to confirm:

The “mark all items as read” does not work on my PC (clicking on icon at top of items list).

Opening individual items seems to work OK.

Ok, I’m able to mark a feed as read with no issue. Does this happen immediately or after you read a few feeds? Do you read by folder or by feed? I just can’t reproduce it, and judging from the logs, it seems to be working fine for others as well. I need to figure out what’s different about your case.

I also logged into your account and was able to mark feeds as read (just one), so I’m still trying to figure out what’s going on.

@Samuel,

I usually read “by feed”, rarely “by folder”.

I thought it might be Comcast pulling another one of their bone-head maneuvers, but I get the same results through a VPN.

I have several Firefox Extensions and Plug-ins enabled. See if any of these affect your Ajax update function: