Infinite scroll doesn't work with j/k

On, when browsing through Feed mode using j/k buttons, every so often it will stop loading new items at the bottom. If I scroll up and back down again with scroll wheel, new items start getting loaded again.

It seems like there is endless scrolling support when scrolling, but it doesn’t cover going item by item.

Feed mode and j/k buttons are my primary method of navigation. It’s already an improvement that I don’t have to reload every so often, but my experience won’t be complete until I can navigate through all my unread items this way.


Yep, I also have this issue. I am using too.

This is a super annoying issue. I actually made an attempt to fix it, but couldn’t figure out what the heck was going on in the js after a few hours and gave up.

using the main site and I have this issue.

Can somebody describe what’s happening? If you hit ‘n’ it loads properly, but hitting ‘j’ makes it not load anything else? Are you able to scroll either the story titles pane or the feed pane and the rest of the stories load? Does it only happen on specific feeds that have very little content and therefore the stories in the feed view are next to each other? Is this in Split or List view?

Hitting ‘n’ lets you jump to the next unread item. Scrolling still works in this situation, and by scrolling up and then down again more stories appear. Basically the only thing that doesn’t work is loading more items by hitting ‘j’.

It happens in the “All Site Stories” list in unread-only mode and list view, even when there are dozens more unread stories available.

Any more questions you have I’d be glad to answer: this is pretty much the only issue I still have with Newsblur, everything else is solved.

Here’s a screenshot: if I press ‘j’ in this situation, nothing happens.

Just giving this a bump as I came to describe the exact same issue.

I am a paid user but it only loads 10 articles at a time. So basically to read news in a feed with more than 10 articles (or the all sites feed) I need to use J (or arrow keys now) to read 10 articles, then use my mouse to reclick on the feed to load more articles.

If I scroll with the mouse it works fine. I tried that for a little while but much prefer using j/k to navigate between articles like I was with Google Reader.

Like the last person, this is the one and only issue holding me back from loving NewsBlur.

1 Like

when you hit the 10th article, try hitting ‘n’. Let me know if that works.

The behaviour is kind of weird. Sometimes N works and refetches the feed and other times it stalls out. When I say stalls out, I mean neither n nor j nor down arrow do anything. I have to click on the name of the feed to fetch again.

But j and down arrow do this after 10 articles every time – very predictable. I had accumulated 50 articles to read this morning. After 10 articles, 3 times n allowed it to continue and 2 times it did not and it stalled. I have no idea why.

Like I said previously: hitting ‘n’ works. But since I’ve got j/k hotwired to some buttons on my mouse I’d really appreciate it if ‘j’ would work as well.

Same here: n/p works but I’d really like j/k to work as well. Thanks!

For me, something happened yesterday and this is not working the same as before. It is no longer predictably stopping after 10 articles (it rarely makes it that far) and the n key is not working.

At the moment, I have a separate window open with 56 unread articles but no key will open the next article. Not n, j, down arrow. None.

I have been using “Show 1 article at a time” but I will start trying it with show articles to see if that makes it better.

Truthfully, I would adopt any keyboard method that would let me scroll story by story if any of them worked. But they all appear to not work over many articles at all.

This is in Split view only.

This problem is the only thing keeping me from upgrading to Premium and committing to Newsblur - otherwise, I’m still looking.for a feedreader.

Yes, agreed

I’ve updated Sam pretty heavily (sorry if I got on your nerves Sam!) on this as you can see on my post:…

The last update I’ve received from him - he’s very communicative! - was that he is still gathering evidence in order to fix it.

Seems to be fixed now.

Awesome! Thanks so much.

Works for me too! Thanks!

Yup, this was fixed last night. One common pattern that was hard to suss out: everyone who experienced this resized their story titles pane to a tiny amount. If you want to hide it, use shift+t. I set a minimum height, which fixed the auto-pager.

1 Like

Hurray, it’s working perfectly now, thanks! I don’t like the story titles pane, thanks for letting me know about the hotkey to disable it. :slight_smile: NewsBlur FTW!