Ghost unread items

(Firefox 9.0.1 on MacOSX 10.6.8)

This happens to me on multiple feeds. I will read all the items in the feed, but NewsBlur tells me I still have an unread item. I click on the folder, and get nothing. I click on the feed, and all the items have been read. If I click on the “Next Unread” button, sometimes the list starts scrolling as if it’s looking for the unread story, and then it gives up and never finds it. Reloading the NewsBlur page does not work – I have go to the folder and manually Mark all as Read.


Same problem (FF 9.0.1/Windows 7).

Me too. ™ I’ve always just lived with it.

There are possibilities I’m happy to explore, but know that this doesn’t happen to me at all. What I’m more concerned with is that after you refresh the page, the unread count stays wrong! That should definitely not be happening. Can I just confirm that this is the case, or once you force a count, it is correct?

Reloading doesn’t seem to do anything. Eventually it corrects itself, I think.

How do you force a count?

Two ways: wait 60 seconds and counts will be automatically updated (notice that yellow flash?) or reload the page and it will immediately update (same yellow flash).

I have a beta branch that makes those counts update in real-time. In fact, it’s working great for me, but there are some kinks that I’m ironing out before I deploy to everybody.

Oh yeah, I can reload the entire page in the browser many times and it still thinks I have 1 unread story in that Tribune feed. The only way for me to fix it is to force Mark as Read.

No yellow flash to be seen, reloading’s not working.

FWIW I just opened NewsBlur in Chrome 16.0.912.75 and Safari Version 5.1.2 (6534.52.7) and I have the same behavior.

Also, amusingly enough, I now have 2 ghost items in that feed.

What’s your username?


I have seen this issue too but the phantom number usually clears out after the 60 second refresh. Firefox 9.0.1/Ubuntu

I see this every now and then too, but it clears itself up pretty quickly.

I saw this a lot with folders that had YouTube feeds in them. Refreshing didn’t help and as noted above, only marking the folder as read made it go away. I don’t think I’ve seen it in a while, though.

I’ve currently got some ghost items in my feed (account Laptop765) The “YouTube” folder shows 1 unread but clicking on it shows no entries. The “Gaming” folder shows 5 unread but clicking on it only shows two. I’ll leave the folders alone until you say otherwise so you can take a look at them.

The question is always – do the counts correct themselves if you refresh the page? If so, then it’s something I’m going to be fixing at some point soon. In fact, I have an experimental branch that gives real-time counts, but it’s a bit unstable and doesn’t work perfectly yet. If the counts stay the same, let me know. And if you *really* want the counts to be correct, just insta-fetch the stories and the counts should be updated.

They do not correct after refreshing (I tried a Ctrl+F5 refresh and also logged into an Incognito window to eliminate caching as a factor.) I also insta-fetched one of the broken feeds and it still shows five unread even though clicking on the folder only shows two unread feeds. Insta-fetching one of the others did result in the unread feed entry turning up in the folder.

I have the lingering unread counts as well, but it will auto-correct in a short while.

The delay of not updating right away causes me to click on the link a few more times to get that last article or two that I missed, to find out I didn’t miss it.

The real reason this isn’t getting fixed is because I can’t reproduce it. Unread counts are nearly always correct for me. I’m not sure why they update incorrectly, and I’ve tried to place a bunch of checks to make sure it is correct. It’d be nice if after you exit the feed, the unread count is updated, or even periodically updated to match what the server has. But it should always be correct.

Anybody know of a clear way to reproduce this? Does this happen constantly or just annoyingly often enough?