Cannot delete feeds with iPad app

I cannot delete feeds using the iPad app. After choosing to delete a feed, I get the spinning progress wheel and a “Deleting…” message that just stays there until I do something else. The app doesn’t freeze - I can go to another feed just fine and the “Deleting…” message goes away, but the feed I tried to delete is still there.


Try downloading the latest beta from your iPad:

Let me know if that takes care of it.

I didn’t download the beta when you recommended it, but I did download the latest release the other day in the app store. I was still unable to delete feeds. Then I went to download the latest beta, but get a “page cannot be loaded” message when I click to “Install the NewsBlur app”

Where is the feed you are trying to delete? Is it top level or under a folder? Do you have any folders at all? Are you able to delete it on the web?

This should have been fixed in the latest version, so I’m wondering what I broke in the fix.

Top level - I have no folders.

I touch the site name in the sidebar, the side bar changes from a list of sites I’m subscribed to, to a list of site stories. At the bottom of the sidebar is “Mark all as read” and a settings button. I touch the settings button and then “DELETE THIS SITE”, respond to the “are you sure?” prompt with “Delete” and then get the forever spinning wheel.

Deleting from Safari on my iPad or another browser on my computer works fine - it’s only broken within the app.

Ack, I cannot for the life of me reproduce this issue. Trying with both iPad and iPhone, and with and without folders. It works every time.

I have the same problem. I tried waiting about two minutes but the Deleting… progress message didn’t go away. The feed I’m trying to delete is not under a folder (although some of my other feeds are) and has two unread articles. It’s a feed I subscribed to several months ago, however I subscribed to a new feed and tried deleting that and had the same problem.

I’m using NewsBlur v1.8 on an iPhone 4S with iOS v6.1.2. I tried deleting and re-installing NewsBlur but it made no difference.

1 Like

Same problem here. I can delete a feed on the web without a problem, but it fails on each iOS device I’ve tried. It failed both before and after I upgraded to a premium membership. It fails for new and old feeds both in directories and in the top-level.

On each device I’ve logged out multiple times, re-installed v1.8 from the App Store, and installed v2.0 multiple times.

iPhone 5 with iOS v6.1.4
iPad Mini with iOS v6.1.3

If there is anything else that you would like me to test then please let me know.

1 Like

Any update on this bug?

I’m new to NewsBlur, and also have this issue.

Third-generation iPad, as well as iPhone 4S, both running iOS 6.1.3 and NewsBlur 2.0, with a premium account.

Whenever I attempt to delete a site the app will sit and spin for as long as I let it, with sites both in folders and at the top level.

This is the most bizarre bug I’ve encountered, because for all I try I cannot reproduce it. Not on my account and not on any test accounts I create. I’m wondering if there’s a very specific condition that it occurs with. And the code is pretty simple. It’s nearly the same code as marking a story as read or opening a feed. It’s just a server call.

The only thing I find in the iPad log is:

Jun 3 10:54:27 Tims-iPad NewsBlur[12280] : Unbalanced calls to begin/end appearance transitions for feeddetailviewcontroller:.

Probably not directly related.

If you want to, we can talk on twitter (I’m @lanaer , I just followed @NewsBlur ), and you can ask me to attempt to delete a site at a specific time so you can check to see if anything shows up in the server logs.</feeddetailviewcontroller:>

It’s undoubtedly a client-side issue. If it hit the server, it’d be deleted! I’ll try some things today, but I’ve been struggling with this bug for 6 months.

Given that it seems to be consistent within an account (I have the same issue on both my iPad and iPhone, same with Neal up above), I have less confidence that it’s purely a client-side issue.

But I guess that’s the point to look at: what bits of account information does the client use when communicating with the API, and which of those could possibly be different for those experiencing the issue.

My account username is tbennett

Feel free to look at my account and see how it is setup.

I signed up with a free account using the iOS app. I later upgraded on the web. At one point I deleted & re-installed the iOS app, but I believe that was before the premium upgrade.

Just deleted & re-installed the app again, doesn’t fix the issue.

I observed the issue while I still had a free account, as well as after upgrading, so that’s not it either.

Feel free to look at my account as well. My username is nealerickson.

I believe I signed up for a free account through the web app. Ran into this issue while still having a free account. Upgraded to a premium account and continued having this problem on every device I try.

If there is anything you want me to test just let me know.

What feed are you trying to delete? I’m in your account in iOS right now…

Basic Instructions at the top level (there’s a duplicate under the Comics and Fun folder).

Hrm, I was able to delete both Basic Instructions and the dupe in Comics with no problem, both on iPhone and iPad.

Curious. Not just account, then.

I refreshed my feeds, see it gone, try to delete something else… and spin spin spin.

Also having this issue on my iPhone. Free account, the feed was on the top level. I just waited till I got on my desktop to delete it.