Cannot delete feeds with iPad app

OK, when run NewsBlur in the simulator it works great, so it doesn’t appear to be specific to my account. Samuel, are you running debug builds on your device or installed version from the App Store?

I decided to hook up my iPad and iPhone to Windows 7 running in VMWare so that I could monitor the traffic using Fiddler. For whatever, reason the /reader/delete_feed and /reader/delete_folder requests are never actually executed. These requests never show up in Fiddler.

  1. Open application and I see calls to /reader/feeds, /rss_feeds/icon, and so on.
  2. Open Freakonomics feed and I get two requests. /reader/feed/249669/?page=1 and /reader/feed/249669/?page=2. Perfect.
  3. I click the settings button, select “Delete this site”, the “Deleting…” HUD is loaded. But, no new requests…/reader/delete_site is never called.

Bug in ASIHTTPRequest?

Neal, wonderful diagnosis. Now, I did already know that the request wasn’t firing, because I can monitor the server very easily, and if the deletion request makes it to the server it’ll work fine. But that code that comes right after the alert confirmation dialog works for most users, so why not the others?

Thanks, Samuel. Well, I finally had a chance to build and debug to my iPad and of course it works fine. Honestly, I’m at a loss now. I was hoping that it wouldn’t work so that I would have something to work with.

I think I may have a fix and will try to release it tomorrow to review (which means next week for a release).

I am having the same problem in an iPhone 4S running the latest version. Any help would be greatly appreciated.

Mine is in a folder, not top level.


UPDATE… I installed the beta via the link you provided and all is well. It seems to have fixed the spinning wheel delete problem. It deleted the feed now.

Thank you,

I have this problem with the current iPad app from the App Store. The feed I’m trying to delete is TechCrunch in case you want to try to duplicate it. (For the record, I like TechCrunch but we have it in one of our other accounts; I was using it in this account to evaluate the training feature).

I’m having the same issue (endless “Deleting” when trying to delete a site using the iOS app -latest version on iPhone 5). Top-level and lower.

Download the app I linked to at top. It’ll fix it.

Are you waiting for iOS 7 to finalize this version for the App Store? Just curious, especially since I don’t know how to install an app that isn’t in the App Store.

The app can’t be installed from the link above. How many years will it take to update the app in the AppStore in order to fix this problem? This bug was reported 9 month ago! Given the very low rating in the AppStore and a lot of negative comments about it, it seems like I am not the only one who is unsatisfied with the performance on ios.

That link should work. I just pushed out a new version. Anyway, the real issue is that this only failed on a few phones for some reason. Most of the time, deleting a feed worked fine, which is why it took so long. Sure, if it was your phone that didn’t work you felt slighted, but it worked on the majority of installs.

To install from that link, visit it from your iOS device. It should install with no issue.