Washington Post feed errors

http://feeds.washingtonpost.com/rss/h… has been behaving very strangely the past few weeks. It currently is not reflecting new content and “Fix this misbehaving site” recommendations don’t seem to fix it (despite showing “OK 200” responses). Sometimes when removing and re-adding, an entirely different feed will be used (from a different site, no less). The feed seems to validate alright and other RSS readers don’t seem to be having a problem at the moment.

1 Like

I went ahead and removed all 44 of the duplicate addresses pointing to this feed. Try again, it should now work.

Maybe it’s working now? I see new content, but even after removing and re-adding the subscription (and refreshing) the context menu still shows a “Fix this misbehaving site” option, which most other feeds don’t display.

The newsblur feed does display 2 entries from the year 2102 that I don’t see in the raw feed, but I’m guessing they probably existed at some point and the origin site’s embarrassment is cached for posterity in newsblur. Not sure if that’s contributing or not, just giving as much detail as I can.

Also, when clicking “Fix this misbehaving site”, the only interesting thing I see is that the “Change website address” log shows a lot of “Feed has no original page. (404)” entries, despite “http://www.washingtonpost.com?wprss=r…” resolving fine for me.

Thanks for looking into this.

I see this is quite old, but I am having this same problem with NewsBlur in the Firefox browser on my PC, and in the Android App. The context menu for the Washington Post politics and homepage feeds shows “Fix this Misbehaving site”. I see two articles from 2012, one having to do with the Romney campaign, and these remain at the top of my feed.

When using the “Fix this Site Option” I get no positive results. Under the recommended option 2, I see an “OK” when I first added the site, then a couple “Not Modified (304)”, followed by an “HTTP Error (404)”, and finally a “Not Modified (304)”. I tried to change the feed address to what was listed here: http://feeds.washingtonpost.com/rss/politics, but still have the same problem.

Under option 3, I have a string of several “Feed has no original page. (404)” errors.

Thanks in advance for any help with this. I’m new to rss, really enjoy NewsBlur, but
not getting the Post is killing me.

Ok, I cleared out many inadvertently duplicate washington post feed URLs. Try adding the feed you want. It looks like WashPo Politics shows fine: http://www.newsblur.com/site/1274/politics

And the homepage: http://www.newsblur.com/site/197942/washington-post-breaking-news-world-us-dc-news-analysis

Thanks for the speedy reply! Hmm, I seem to still be having the issue of what looks like 3 old articles appearing at the top of the feed. I see these articles in the links that you included as well.  Below these, it does appear to be loading the feed. See the screenshot. I’ve tried this in Chrome in case it had something to do with the browser, but issue remains.

Thanks again for your help,