Twitter images don't load on Android

#1

Twitter images doesn’t load on android

I reported this a year ago too


#2

We’ve solved many problems with image loading on Android over the years, but for whatever reason it keeps coming back.

Can you post a screenshot of where the missing image should be?

1 Like
#3

I also created a ticket for this issue, so it’ll get looked at soon enough.

1 Like
#4

https://forum.newsblur.com/uploads/default/original/1X/6ac758a2e936e6f722a091c7a141d3b3de115d2f.png

#5

Thank you

#6

This is also another bug that still happening

Android: “Loading…” text but story doesn’t load. Tapping out then in shows the story. #1163

This bug is also probably related with another bug from 2 years ago

#7

There are 2 “identical” features requested and listed on github

This is the one I requested sometime ago

The first link is with a low priority tag,while my identical suggestion is with a high priority tag.This feature ia a high or low priority?:rofl::thinking:

#8

Thanks, I’ve updated those issues. The one about the broken text view is one I’ve pinged our new Android dev about and hopefully he’ll get to it soon.

#9

Thank you so much

I’m also able to reproduce the bug of Android: “Loading…” text but story doesn’t load. Tapping out then in shows the story.#1163

#10

@drhouse Does the story loading issue happen only when you try to view a story that just came in or is very recent?

#11

@andrei
I’m not sure,since I became a newsblur user I only let articles unread once, for more than 14 days.
But I think that this issue happens only when I try to view a story that is very recent.

1 open the newsblur app
2 wait the app to start syncing and start downloading new articles
3 open the feed or the “all stories” tab
4 you can see the new articles showing up
5 sometimes I wait for the bottom text “storing unread articles” to finish and sometimes I don’t,I don’t remember
6 open 1 article or a few articles
7 some articles will load the full text while some articles will just show a loading message
9 usually at least 1 article will freeze in the loading message,so the full text won’t load (even though I know that the newsblur app already downloaded the full text content,because I waited almost “1 minute” with the article opened in the loading message)
10 Click on the Story button then click on Text button and you will see that the full text content for the article will load

#12

If you switch from Story to Text view (or vice versa), the image loads?

#13

Yes,the images,videos and the full text content loads.

I set my articles to always open using the story view mode by default,so I don’t know much about the text view feature.When I open the articles they are already in the story view mode,some of them don’t load sometimes and that’s when I set to text view and switch back to story mode.

I don’t know if I use the text view by default, the same loading message bug will happen or not.

#14

I forgot to mention that my question was in the context of the issue Android: “Loading…” text but story doesn’t load. Tapping out then in shows the story.#1163 reported above but it probably should be discussed in another thread.

@drhouse thanks for the detailed steps, I’ll see to reproduce the issue

#15

@andrei

Both of them are really related anyways.
The reply that I mentioned you was also in

I just read the last Samuel clay reply on https://github.com/samuelclay/NewsBlur/issues/1163# and he probably misunderstood the purpose of this thread.

I made this thread because twitter images doesn’t load,even though I always read articles on the story mode and I wait them to be downloaded,even old articles doesn’t show any twitter images at all,even if I wait a lot or if I just open the article after a few days.Clicking 2x on the story mode button probably doesn’t “fix” that bug at all,I’ve never tried doing that just to see an twitter image.

The other bug is that,the text content and everything else doesn’t load sometimes (not always),and the app stuck on the loading article message,in these cases I can’t see anything besides the article title till I click 2x on the story mode button.

The bugs are different,but both are about loading problems,1 bug is that twitter images never loads no matter what,and the 2 bug is that Sometimes nothing loads,but this 2 bug can be fixed by clicking 2x on the story mode button.