Twitter feed not working

The announcement of new Twitter support says you can add as a site. However that doesn’t actually work: when you try it complains that you need to set up a connection to twitter with a twitter account.

I don’t have a twitter account, nor do I want one. Does the feature work as stated in the announcement or not?

1 Like

You have to have a Twitter account because it can only add folks you already follow on Twitter. I’m sure the Twitter API limitations have something to do with that. You can always make a private Twitter account with some random username so no one can find you and follow the same ones you are interested in following through Newsblur. I use it for some Twitter accounts that don’t post as often or post important information that I don’t want to miss if I am not actively looking at my Twitter feed (like the bus company in my town).

That sounds mostly right. I use NewsBlur to follow some folks who I don’t follow on Twitter. I notice that I get that error message if I try to NewsBlur-follow someone w/a private Twitter account. Maybe I could NewsBlur-follow those accounts if my Twitter account followed them?

I ?guess? you need a Twitter account because the Twitter API demands it. Using a random-username Twitter account sounds like a good workaround for that.

Just make a burner Twitter account. NewsBlur uses your Twitter access token to fetch feeds on your behalf.

1 Like

I *do* have a Twitter account, but I can’t figure out where to set it up so that I can subscribe to Twitter feeds. The error message says to go to “Manage : Friends” but I don’t see that option.

PS: Thanks for making this possible, Samuel!

Johnny, you have to be on the website and not the mobile apps. You click the settings icon in the bottom lower left and select “Friends and Followers” and you will see the options to connect your Twitter account. If you are on the website home page and see the “Manage” section on the right, you can click “Followers” to get to the same place.

Thanks! That did the trick.