Trying to train, but only getting barf


#1

iOS 7.1 iPad Air. Completely unable to train. I tap the author, it briefly flashes green, then it goes to grey again and I get a server barf. This issue has been going on since the newsblur update. It generally worked fine before that.


#2

I’ll investigate this one. Another user had it, but when I went to investigate, it started working for them.


#3

I tried uninstalling the app and re installing. No joy.

Observation…
It appeared that my attempts to filter out foreign language authors resulted in me favoriting them sometimes, so I tried ignoring what I see on my screen. I tap once, wait for the barf, tap again, wait for the barf, then close the trainer. As far as I can tell that works. Which means the training might be working but the visual feedback on the iPad is not?

Hope that helps.


#4

Having same problem on iOS v8.1.
One tag in particular was added by me in error. I can’t delete it only neutralise it. However it refused to change state saying “server barfed”.

It seems that changing state of at tag while training a story produces a server barf and does NOT change the state BUT if you do the same while training a SITE then the server still barfs but the state IS CHANGED.,


#5

This is a bit of an old ticket, but in those 5 years I’ve trained plenty and haven’t run into this issue. I will say that tapping on tags/authors will sometimes skip around between green/red/neutral. What’s happening is that it’s detecting two taps but it’s a hard bug that i haven’t solved. Worse case you just have to keep tapping on the tag/author until it goes the color you want.

But yeah, the server erroring out isn’t something I’ve seen and can’t reproduce.


#6

Thanks for quick response.

Seems like I was wrong. The tag does NOT change state after the server “barfs”. It’s pretty consistent. For my tag “USD” I get “barf, barf, barf” everytime. This particular tag won’t change state on the web version either.

However I have an idea. I’ve been investigating this a bit more and it is possible that the problem may be tags with “/“ embedded within.

Go to “train site” and get a list of site tags. If I select “AUD/USD” to change from Green to Red that tag does not change but the “AUD” tag does change. I can see it happening when I press “AUD/USD” which is Red and it’s actually “AUD” that changes to Green and “AUD/USD” stays Red. Very wierd.

I also never had an “AUD” tag before, it seems to have been added automagically… but I also see I no longer have a “USD” tag.