TechBargains timestamps incorrect

The feed is displaying “8:00pm” as the timestamp for ALL posts.

1 Like

UPDATE: All incoming posts from show a time stamp which reads “26 June 2013 8:00pm”!

This seems to be the only feed affected by this issue that I can see.

This issue is happening to me as well. Throws me off especially when viewing all articles because Newsblur organizes the posts randomly as they come in.

Is there anyway to fix this issue? I’ve tried deleting and resubscribing to the feed with no change.

It seems like it’s the feed’s fault. You should contact them.

I’ll contact them and see what they say. Thanks for the response Samuel.

Samuel, I’ve sent an email about the RSS issue. Waiting to hear back. However, using another reader, go read, the times for come it with the same time stamps as the website. So it doesn’t seem like it’s a feed issue.

I have same problem with this:

All items are marked published as: 3:00am

The feed is valid:…


"interoperability with the widest range of feed readers could be improved by implementing the following recommendations.

line 78, column 51: Problematical RFC 822 date-time value: Wed, 03 Jul 2013 17:26:00 +0300 (25 occurrences) [help]

Wed, 03 Jul 2013 17:26:00 +0300"

The problem is 2 space characters before the timezone instead of 1 space (EDIT: it doesn’t show in this post because this message system seems to remove more than 1 consecutive space chars). Small error but you could be a bit more lenient about this when parsing. Your service (I’ve tried desktop apps also) is the first that can’t handle this small error.

Anyways, I’ll be contacting the feed authors.

Seems that something is now wrong with the feed coming into NB. Not seeing any updates to the feed since before 12 PM EST, yet ‘go read’ has received 20+ updates since then.

Is there any progress on getting this resolved? Seems like it’s a simple fix by Toussanter’s earlier post.

Ahh, I don’t control date parsing. I use feedparser, which handles date parsing. I could try upgrading feedparser, but whenever I do that all hell breaks out. I’ll try it and see what happens.

Samuel, whatever you did seems to have fixed the feed. I’m seeing them come in with the proper time stamps now.


Same here, proper timestamps with my problematic feed too. Good job.