Stuck on opening page describing newsblur, new features, community feedback. Can't go to my feeds!

I get stuck on the main page, as described above. It welcomes me with my user name but I can’t advance to my feeds. There is no option to click on anything except on the bottom right hand corner where I can click on FAQ, etc. See:

This is a problem that seems to come and go on firefox. I have checked all my extensions and plugins and they are up to date. This does not happen on chrome.

On chrome, it looks like this
and I can easily view my feeds.

Any advice would be appreciated. Oh, windows 7.


1 Like

You can press shift-u to toggle the sidebar, no idea why it would hide itself though.

Thank you. Shift-u works in chrome but not in firefox newsblur which is the one that is stuck. A few weeks ago I ended up setting firefox back to factory settings which fixed this. So, it is a firefox compatibility issue and if I didn’t need 58 tabs open all the time I would use chrome but…

Would prefer to use newsblur with firefox.

Thanks again.

Can you show me a list of plugins that you are using with Firefox? Have you tried disabling all of them and seeing if NewsBlur works?

thanks for helping. I just fixed the problem. I had some persistent malware ad scorpion saver in my control panel. I went through an aggressive round of uninstalling it and now newsblur works. The problem may resurface because I have had to uninstall scorpion saver before but at least I know now how to solve the problem.

I had thought that it was a java problem. It was strange that newsblur worked on firefox, then stopped working on firefox, and then stopped working on chrome. The breakthrough realization was that i could sign into my account on a different computer. That realization forced me to think beyond the browsers. It was so frustrating not to be able to get my feeds!

Thanks for answering and trying to help.