"Story" view option not working.

I have been having a problem for the last few days, when i switch to “story” view of a feed, nothing shows up. “Original”, “feed” and “text” all work fine.

Is this a known problem? Is it just me?


Which feed it is happening to? It’s possible a feed has disabled the Story view.

It is happening to every single feed Im subscribed to, even feeds that worked fine a few days ago.

Nothing changed, and I just tested it and it works fine. Ohh, I have a feeling you’re on Firefox, no? You’re hitting the active mixed content warning. There should be something you can change in your address bar that enables mixed content (http vs https).

1 Like

Aha! Fixed. Thanks heaps for the quick response.

I’ve had this problem for the last 2 days (10/23/2013)

Firefox? In that case it as as noted above by Samuel due to “Mixed content” being blocked. You’re visiting the https version of Newsblur but the item you’re trying to load in Story view is using regular http. It used to be that Firefox just wanred you about this but since a few version back (Version 23 I think) the default changed to actively blocking mixed content.

You can disabled the block for specific sites. If you look at your navigation bar where the site url is, over on the left side next to the back and forwards buttons you should see a shield icon, click it and it’ll tell you about the mixed content being blocked. There is a button in the popup that says keep blocking, on the side of that button is an arrow, click it and a menu will drop down from where you can disabled the blocking for the site you’re on.

EDIT: If you don’t see the shield icon Firefox might be set to not show the warning. You can fix this by typing about:config in the address bar, click OK for the warning, now type warn_viewing_mixed in the search field, it should give one result, if the value is set as false just double-click it and it’ll change to true and the warnings should show up. You might have to reload Newsblur or restart Firefox.

That worked, thank you!!

I’ve recently started seeing the same problem with Chrome-stable… it’s unclear to me if the cause is the same or not.

Could be the same thing. Don’t really use Chrime myself but from what I could fine Chrome has the same kind of filter, not surprising really.

This might be of some help for you

I’ve had this same problem for weeks now in Chrome on Mac. Very annoying. Works fine in Safari. Still trying to find a solution.

@Rich What I linked above should be the solution for Chrome.

I’m having this problem in OS X Chrome, Firefox and Safari. Neither text or story view loads content for any of my feeds. There’s no shield up by the URL. I’m out of ideas now :wink:

Well Firefox and Chrome should work mostly the same on OS X to my knowledge but I’m not a OS X user so can’t really check.

I guess we could at least figure out if it is the mixed content filtering you’re running in to or if you are having a different problem. Are you browsing Newsblur via HTTPS? If you are, try just HTTP (just remove the S from the URL) and see if it works then, if it does then we know it’s the browser’s mixed content filters messing things up.

I’ve switched from http to https and back, and taken off the ‘www.’ for good measure too!

If it doesn’t work with just regular HTTP then it’s not the mixed content filters. No idea what else it could be.

Thanks for trying, Hampus.

New clue: text and story views DO work on folders of feeds, just not on the feeds themselves. This is a welcome work-around for me, but hopefully this problem will be fixed or whatever I’m doing wrong will come to light.

BTW, I really love newsblur. I was a diehard google reader user, and now I like newsblur much better.