Story view not working on all sites.

Story view not working. Not working in Firefox, Chrome, or IE. Updated browsers, on Linux or Windows. With all sites. Was just working the other day. Including a site that I control that I know is not forbidding embedding.

1 Like

Whats an example site that isnt working? (rss feed is…………

I can go on.

All of the feeds I subscribe to.

Thank you for the response.

Any updates on this?

I have never seen anything in the story view on any of my feeds(user for 2 years). I figured it was some FF add on i installed, so I tried turning them all off today when i saw this ticket, but still no content in story view. Chrome and IE also produce nothing in story view for me.

user name:robynnc if that helps at all.

Me too but on the Android ap. Always had problems with the story view, sometimes it shows a different story from the same site (perezhilton) any other times it just shows the text footer but no content (

Of all the browsers I’ve tested, Story View works only in Maxthon. In IE, Firefox, and Chrome, I get only a blank screen. I’m running Windows 7.

I figured out what the issue was for me. Since you log into NewsBlur under HTTPS the newer versions of Firefox is blocking insecure content, which the story feed tries to load the page as is and thus is “insecure”.

You can turn this off per session. But if you close your browser and then come back to NewsBlur it will happen again. The only way I could find around permanently it was to go into about:config and turn this feature off completely.

You can consider this closed for me, it was my browser, not NewsBlur.

Thank you.

1 Like

Thanks for the tip!

Thanks Cynnyr! I have an existing bug filed with Mozilla/Firefox to address this exact issue. I just need some warning so I can tell the user why it isn’t working.…

To get around this, you need to allow mixed content.

I’m having the same problem on Google Chrome. A very subtle shield pops up on the right hand side of the address bar where you can authorise running the scripts, which fixes the problem.

Part of the problem is that I can’t run Newsblur on a normal HTTP connection. Even if I go to preferences and turn off Secure Connection, log out, close the tab, new tab, log in again, I still end up with an HTTPS connection.