Sound typically doesn't work from the in-app browser on latest iPhone 5 iOS, especially when playing a YouTube video.

When clicking on a link from a feed item in the Newsblur iOS app for an iPhone 5 on the latest OS, the in-app browser opens. If the destination in the browser includes sound, it typically doesn’t work, especially for YouTube links.

I saw one prior report of this a few months ago that said the latest version fixed this, followed by a comment that said the poster had spoken too soon and that sound is still not working. I am running the latest version of Newsblur.


I just watched a YouTube video on the iOS app and it worked fine. Do you know if you have any settings that might prevent sound?

Sadly, no. All sound works fine in all other apps – indeed, if I copy and paste the url that won’t have sound in newsblur into Safari, it works just fine. Really puzzling. Just tried it with a Vimeo link, too, and that didn’t work with sound, so it’s not YouTube specific.

I just tried deleting and reinstalling the app, and the sound is still missing.

Try downloading

Installed without trouble – but no change in the sound not working. Sound from all other apps still working normally.

I’m having the identical problem with my iPad (3rd gen). This was true with IOS 6 and is still true with IOS 7. I’ve tried uninstalling/reinstalling the app, but no change. I’ve been through every item in the settings app and can’t find anything that could affect this. Any other ideas?

Never mind, I just figured it out. The browser in Newsblur uses the system sounds. If they are muted, videos and the like don’t work.

I wish it were the case for me! Unless there’s some hidden place for setting system sounds? To my knowledge I’ve never turned them off, and I still have the sound issues in (and only in) Newsblur.

In iOS 7, swipe up to bring up the new settings control. There are five circle icons in the center, the fifth one being a bell with a line through it. If it’s white, mute is on, if black, mute is off.

Funny, on my iOS 7 that last bubble is for the screen orientation. Perhaps on an iPad it represents whatever the physical side switch does not? In any case, I’ve still got the sound problems even with system sound turned up full.

I think this is still a bug (see…). The ring/silent switch (or software equivalent on an iPad) doesn’t mute the YouTube app, Apple’s music/video apps, or anything else; it shouldn’t mute the browser sound in NewsBlur.

This issue occurs on both iOS 6 and iOS 7, iPad and iPhone.

To be honest, I’m really happy that it mutes NewsBlur, since I hate having apps play audio when I have my phone on silent. In other words, I’ll get to this bug, but I have no idea what caused it. I’ll put up an iOS 7 build probably tomorrow, which may fix the issue.

The problem is more in the opposite direction — particularly on the iPad, if the side switch is set to lock orientation, it can be hard to see that the sound effects are muted when the volume control appears to be working. Whereas if an app is making noise it’s pretty obvious to hold down the volume-down button until it stops.

Oh, wow, that’s indeed the problem: Thank you, Nicholas for pointing it out, and Samuel, for taking it on. I just hadn’t pieced together why it sometimes worked for sound and when it didn’t, even as I moved to a new iPhone, but the answer is that it’s tracking the ringer switch, as no other app that I know of does. (I keep my ringer off nearly all the time.)

It’ll be great to have this fixed.

OK, this will be fixed in the iOS 7 version, which should be submitted to Apple I hope by Friday. I plan to push a beta out tomorrow.

Hi, Samuel – any word of the update? The problem still persists for me.