Some of my folders never stop loading....

Since yesterday, the last four folders on my Newsblur page fail to load at all. The first three (Android, Blogs, Image-Video) load normally. The last four, even though new posts are appearing in the counts on the left, never actually show content on the right side.
All I get is the blinking top border as if it is loading content.

If I open one of the four folders and select a individual feed manually, it will load properly on the right. It won’t load if I just select the folder title as I used to or as the top three folders do currently.

I tried the full and list views and nothing seems to get the folder content to display except selecting individual feeds.


A few more points to help troubleshoot:

1 - It may be happening when I use keyboard shortcuts (right arrow) to move and highlight a empty folder. From that point on, no other folder will show.

2 - If I highlight a folder where this problem exists, then press F5 to refresh the page, content displays normally.

What’s your username?



I get this or something similar anytime I view a truncated river (I’m a free user). After doing so, any feed I view afterwards, single or folder, will constantly flash blue (although in my case, it will still load some/all of the feeds items) If the feed has just one new item, the one will display and be read fine but the blue bar flashes…if theres ~>5 or so, only the most recent 5ish will be displayed, and I can read them, then click the feed again to get more. Subsequent folder viewings dont work at all though. And yea, refreshing does clear it

I’m having the same issue, especially with shared stories. Username “subbes”.

I am a paid user and have a similar experience to Jason. I there are more than 5-6 new posts in the feed, then I only get those and then the flashing loading bar at the bottom.

However, I’ve yet to see any unread posts show up even after I read through the 5-6 that are displayed on the page initially.

If this happens, can any of you open up your developer console and take a screenshot of the error message? I’m certain somethings up.

Also, are you in single story mode (only show a single story at a time, instead of all stories in a list)? Full, split, or list view?

So it looks like it may have been related to a broken app server (I have 40 of them in a round robin distribution). I have no idea why, but many folder requests were getting sent to the down server. Killed the server and now everything looks peachy. Sooo… let me know if it works perfectly now.

1 Like

Just tried it about 15 seconds ago and although I don’t have a lot of stories at the moment (just checked an hour ago and marked all as read), the ones that were there worked as normal.

If it happens again, I’ll update this thread. Otherwise, you got it. Thanks again for the excellent tech support!


Yup, all of my feeds are now loading all the posts. Thanks for the help Samuel!

Seems to have fixed my problem as well (I had posted in the other chain of this discussion).

Daniel - Cahwyguy