Some images not displaying in iOS app

In Text mode, images will sometimes display as only an outline with alt text. Tap and hold to View and zoom also displays a placeholder. Switching to Story mode will sometimes fix the problem, but not often. If it still doesn’t display within the context of the story, the image is sometimes viewable by tapping and holding to View and zoom from Story mode, but not always. 

This issue happens on several different feeds, with images hosted on several different sites. 

1 Like

Any examples? The Text importer tries to rewrite images so that they point back to the original site, but that doesn’t always work.

I’ve had the problem recently with, Dad and Buried, Girl’s Gone Child, all in my feed (dianaschnuth).

Also having the problem with my own blog’s feed, inconsistently with different images in the same post. is a consistent offender. too.

Another observed behavior: I’ll refresh my own blog’s feed by going to the feed, then the gear icon, then insta-fetch stories. The feed will refresh, and a thumbnail will appear in the list. When I go back to the All Stories list, the thumbnail image will appear for a moment, then disappear. The image will then not be visible in the story itself.

Not sure if that helps.

This happens pretty consistently with the feed for Freefall. All I see is a gray box instead of the comic image. Works fine on a desktop Web browser.

I just found a workaround for this. If you attempt to email the article, the image should appear in the mail compose view that slides up.

Obviously, it would be great if it could actually appear in the article area as intended!

This works fine in the simulator, too, if you’re wondering why it isn’t showing up… (tried both with the latest direct download and App Store versions of the NewsBlur app).