Site not updating

A WordPress site is not updating its feed and has not updated since April 23rd. Visiting the site’s feed, shows that the xml feed of the site is updated with new articles but Newsblur doesn’t reflect them.

I tried doing an instafetch which did not bring in any new articles. Reviewing the site statistics show that feed and page fetch are OK. I tried deleting the site and resubscribing but it only brought in the articles up to April 23rd.

The only thing I noticed is that the feed URL has an odd parameter after it which the site does not list. If I add the parameter to the URL and visit it in my browser, it still works correctly and shows the latest articles. I’ve only noticed it on one site but I’m concerned it could be happening to my other subscriptions and I’m missing content.

Newsblur feed URL:



It looks like that site forces SSL and requires SNI, I don’t think newsblur supports SNI yet.

As soon as Ubuntu’s latest LTS release (currently 14.04) receives Python v2.7.9, SNI support will be provided. I just upgraded and it’s sitting at v2.7.6.

So that looks like April 2016, which is less than a year away. Sorry folks, but SNI just isn’t easy to get otherwise. It’ll be a mess if I try to use a custom Python and then have to downgrade it when the latest LTS comes out. I do that form time to time for some libraries, but it’s never easy and in this case it’s only a couple feeds that have that issue. As soon as 16.04 LTS is out I’d be happy to upgrade.