Sharing Bookmarklet No Longer Works

Could it be sent over https instead of http? That should fix the problem for us.

There is other personal information leaked unencrypted as well - like the email addresses of people you’ve emailed stories. So https would fix several issues.

I don’t know what changed, but the bookmarklet now works perfectly for me. Thanks, Samuel!

It still doesn’t work for me while using HTTPS Everywhere

Yep, I retooled the bookmarklet on Friday, so it should work far better on some sites.

I can confirm it’s back in working order for me, too. Thanks!

Hmm, whereas the bookmarklet worked fine for me in the past, as of today it has quit working at all. I deleted it and re-added it just to make sure I had a fresh copy.

When I click it, about a quarter of the time, the dialogue never comes up. The tab title gets “(Sharing…)” prepended to it, but nothing else happens. Clicking again usually brings it up.

When the dialogue does come up, clicking the “share this story” button is a no-op. Clicking it multiple times has no effect.

Firefox 17.0.3esr on Win7-64.

Example page that I cannot share:…

So the text extractor doesn’t always work. For that page, just select the text by hand and then open the share bookmarklet. That should populate it. You can then edit those fields.

1 Like

Ah! I didn’t even realise that was what was failing. Works beautifully.

I just tried to test share an article from CNN and the pop-up comes up, I click “Share This Story” and… nothing at all happens. No error, no sharing, nothing.

I’m using Chrome and HTTPS everywhere.

I’m getting the same behavior, trying to share . Ubuntu 11.10, Firefox 20.0.

Did the bookmarklet code change recently? Sharing had been working flawlessly for me since the last fix, but today I tried to share an article and again received the message: “Sorry, but there was an error trying to share this story.”

Nope, nothing changed. I’ve heard numerous issues with using HTTPS everywhere, so it’s possible you either upgraded to the latest Chrome or Firefox (which may have issues), or an extension has gone bad.

think its the bookmarklet itself, as it was working fine for a day even after the new firefox update

it stopped working for me just now…

Seems like it is possibly another issue. I am not getting an errors or anything it just does not work, see:…

I’m also seeing problems with this bookmarklet. It’s not sharing in Chrome or Safari on Mavericks, even if I select the text.

Page that isn’t sharing:…