Scrolling Gets Stuck in iOS Version 5.01

Congrats on the new version but NewsBlur has simply not worked reliably since the launch of iOS 9. The new version has made things worse. In many articles the scrolling gets stuck. There’s no way to fix it except quit the app and then go back to the article.


Tell me a bit about your setup. What iOS device are you on? And are you on the 9.2 beta by any chance? Also, scrolling vertically or horizontally between articles?

I’m getting this too on an iPhone 6, not using a beta it’s stuck scrolling vertically on some articles.
This one as an example Einstein’s first proof…

I’m using an iPad mini 4 running iOS 9.1. I also have an iPhone 6 and 6 Plus but haven’t tried it on those devices yet. I use NewsBlur in a production environment so I don’t use beta software.

The problem is vertical scrolling of an article on the right side in both Story and Text mode. Before this update I had problems swiping from one article to the next so I gave up on that gesture and now tap the article in the left column.

I appreciate all the new features but wish you would ship a stability update.

Same here, iPhone 6 with iOS 9.1. Seems to be consistent; every third article won’t scroll, regardless of feed. That is, the first and second articles viewed scroll fine, then the third won’t, then the fourth and fifth are fine, sixth just won’t scroll up or done, etc. As a workaround, I can tap through to the page view, but that’s a hassle.

Don’t know if it might make a difference, but I did switch to In-App Safari for my browser.

I’ve added a ticket for this bug: We should hopefully figure out how to reproduce it soon. Does this happen to other people? What’s the common thread and why doesn’t it happen to me? Can somebody post a screenshot of when it breaks?

Here’s a screenshot. From there I can swipe left or right for previous/next story but it wont’t scroll at all to read more of the current story. Taps all work as normal (on story title to go to story (which then scrolls fine) or for copying.

1 Like

I’m using regular Safari and always have so in-app Safari is not the culprit. Since hard resetting my iPad I cannot reproduce e the problem. Is it possible that NewsBlur has a memory problem for lack of a better term? This could explain why quitting the app helps and a hard reset helps even more.

I get it as well.  iPhone 6 and iPad air, both running iOS 9.1  A article will get stuck and not scroll up or down.  If I scroll left or right to the next or previous article, it might be stuck or not.  Eventually, I will end up with one that will scroll up and down again.  I haven’t been able to find anything in common with the ones that won’t scroll.

I have a feeling this might be related to a bug I reported —…. For anybody for whom this is happening, check if double tapping on the article causes it to unstick.

using latest ios/newsblur version I have this happen as well.  Iphone 6+ only vertically scrolling gets stuck.  Can still move between stories.  does not seem to be specific feeds

This one bites me a lot, usually at the beginning of a story, but sometimes in the middle. Like just now.

Double-tapping did unstick it.

This happens to me a LOT in iOS. If it helps, once it affects one story it will affect EVERY THIRD story until I double-tap (I was crashing the app, but this helps a lot, thanks)

Bingo, I could reproduce it. Going to try and fix it asap.

Looks like this is caused by I’ll have a fix out next week.

Fix is in. If you can sideload apps using Xcode, you should be able to pull from latest and have it work. Unfortunately Apple isn’t approved any updates this week, so it’ll take a week to get out.

Here’s how to reproduce the issue. It happens because we are detecting double taps. But there is a possibility that you perform a double tap but move your finger ron the second tap just ever so slightly that it isn’t registered as a double tap but is registered as two taps connected to each other. 

So just tap and then immediately tap again, but moving your finger slightly on the second press (and when you release). It takes a few tries. But that’ll disable scrolling without opening up the in-app browser. If you do open up the in-app browser, then scrolling is re-enabled on the story.

So if you hit this bug, just open up the in-app browser and when you return it should work OK. Whew, not the easiest bug to reproduce.


Had this issue on iPhone 5s. Great thread. Helpful input. Quick response. I’m a NewsBlur fan.