Real time updates not working.

PubSubHubbub updates do not seem to be coming through. Feeds from Tumblr blogs (which I know to have PuSH) don’t seem to be updated within 6 hours, let alone real time.
These feeds have been imported from OPML, perhaps this is part of the issue?
Oh, and I recently became a premium user.


Could you post an example feed URL, please? Could you add a screenshot of the feed statistics, the section listing the feed and page update times? Thanks.

About 5% of self-reported PuSH feeds don’t work for whatever reason. It’s still a work in progress, but I’d love to know the feed that’s causing the issue.

By the way, you can easily check if a feed is PuSH by right-clicking on it and going to Statistics. That will either say real-time, or tell you how often it is updated. Premium accounts have all of their feeds updated at the very least once every hour. So it sounds like something is broken.

Here are the screenshots. The post that made me report this was the 1:36pm post (the last one). If it helps, my timezone is GMT+10 (AEST).

The same issue here with two feeds, but I’ve already removed them.

I’m looking at it and it looks like the real-time updates are coming in OK.

Well all I can say is I noticed that blog had a lack of posts so I instafetched the stories at around 5PM and found that there was an update at 1:36PM that hadn’t come through.

I think the important thing is that the feed continues to update. I hope that’s happening.

It seems to be. I’ll keep you updated.

Okay, it’s really not. I checked the actual page itself last night (~10pm) and there were updates that hadn’t reached Newsblur yet. Looking at Newsblur’s page for the feed, it shows that the updates were posted at 3pm. That’s 7 hours. There’s a post on the blog that still hasn’t hit Newsblur. I don’t know what’s going on but that feed is most definitely NOT realtime, whatever the system may be saying.

I just instafetched and it picked up the post it hadn’t seen yet. 5 hours late. Maybe I’ll turn my own PuSH node on and do some debugging.

And this isn’t isolated to the one Tumblog. This is all of the ones I’m subscribed to.

Hmm, you got me. Looking at Aurora, it’s been fetched 5 times in the last 12 hours. Those fetches are probably your insta-fetches, combined with the fact that NewsBlur will continue to fetch real-time feeds, just at 1/20’th of the frequency, which is once a day if you’re a premium (since it would normally be every hour).

Got any other feeds? Post the feed address, which you can easily get by right-clicking on the feed title and going to Site Settings. I’d love to see more examples to figure this one out.

OK, noticed that pushes were not happening, so I added instrumentation to find out if the feed is being properly pushed to. You can see it yourself by going to Statistics for a feed.

Here are a couple more:


Going through my 11 Tumblr feed statistics, only one of them has received any pushes.

Not sure if I mentioned this, but most of my feeds were imported from Google Reader before I went premium. Perhaps this is relevant?

Hmm, I think what I should do is that if a feed hasn’t received any pushes in the last week, but it has new stories, cancel PuSH and force it to re-subscribe. I just worry that it’ll be an infinite loop, since the way PuSH works is that it only gets turned on if the publisher verifies your subscription. So this is clearly Tumblr’s fault, but I’m not sure why. I need to invalidate PuSH-enabled feeds that aren’t pushing, but I don’t know what a good trigger would be.

Yeah, I’ve actually worked with PuSH before so I know what you mean. Still doesn’t seem to be working though.

Something else I’ve noticed, the ones that aren’t working are ONLY the ones that were imported from Google Reader. Everything I added after that seems to be receiving pushes fine.

Just thought I’d say those feeds I imported from GReader are kinda important and they’re still not working. Just reset them?

OK, I made a nice change to address this problem. If you Insta-fetch the stories on those feeds, they will now force a re-subscription to a PuSH feed. That should get real-time working again. I checked it on a known-bad feed and it worked. Why it didn’t work the first time is anybody’s guess.

Sorry to make you do the work, but until I have some more data on why this is happening, I’m going to have to try some low-hanging fruit before I address whatever bigger issue it is.

I think this should get everything working, provided you Insta-fetch those feeds. It’ll only take a second. :slight_smile:

1 Like