Original view seems broken

Viewing stories in the Original view seems to be broken, for me at least. Story view works, but when I hit “Original” I just see a white screen, even if I wait a while.

Any ideas?


That’s weird. This happens even after you refresh NewsBlur? What’s your browser/OS? I’m testing over here and it’s working. I’m making a ton of changes this weekend (and all next week as we prep for the iPhone/iPad launch), but I don’t think any of them would change the Original view.

This has actually been going on a while (in fact, I’m not sure if the original view has ever worked). I’ve just been using the story view to see the original page for the few stories I need to.

I’m on OS X 10.8, with Safari 6.0.

Alright, this is strange. Just now, I went to see if I could get anything useful from the error console when I hit “original”, and it worked. The only difference is that I didn’t have any unread stories, so I had to change a feed to show all stories instead of just unread.

However, if I’m looking at unread stories only, it doesn’t seem to work. I swear, I’m not making this up.

I’m using Safari 6 on 10.8 as well. I tried it with setting my sites to Unread Only and variations of Oldest/Newest and it still shows up every time. Is there any data in the console?

Alright, maybe I am crazy. I added a new feed so that I’d have unread stories, then opened the error console before hitting “original”. Lo and behold, it worked.

If it stops working for me again, I’ll try to get some error console info.

OK- not crazy. It did it again. The feed is http://www.smbc-comics.com.

I opened the error console when I got to my dashboard, then opened that feed. This is what I see:

Handling message l10nData
common.js:398[“Setting refresh interval to every 60 seconds.”]
common.js:398[“Setting refresh interval to every 60 seconds.”]
common.js:398[“Setting refresh interval to every 600 seconds.”]
common.js:398[“Navigating to url”, “folder/comic”]
common.js:398[“Still loading feed view…”, 1, 1, Object]

Then, I click “original”, and nothing happens. Nothing new shows up in the console.

If I hit feed view, it works, and I get a bunch of messages about unsafe javascript attempts, which I believe are due to ads on the site.

Oh, is it just this one feed? I seem to recall that SMBC has never worked.

I get this on many different feeds, but somewhat more rarely than often enough to call it broken.

Symptom is the same: go to feed view (usually via hitting Enter) and you get a while pane. Most of the time it’s a really slow website, but many other times, it is more mysterious. If I middle-click the story title to open the original in a new tab, it loads instantly.

Restarting the browser does seem to help sometimes. Easy repro is to load HackerNews is original view and just rapidly flip thru stories. (since HN’s content comes from all different sites of different qualities and speeds)

Has been an issue for at least 2-3 weeks.

Original View has never worked for me (joined less than 1 week ago) in Chrome 21 or 22 on Win7. Just a white screen, and it happens on all feeds.

Error console is just a stream of [“Still loading feed view…”, 12, 12, Object] with the URL objects changing depending on the stream I’m on, and that shows up regardless of whether I’m in original, feed or story view.

Inspecting the store pane indicates it contains an iframe with an empty HTML document, just open and close head and body tags with nothing in them.

If I “j” through the River while in Original View, it displays two crossed green arrows between the Original and Feed buttons, and the content area displays the Feed View. Clicking on Original brings back the empty white story pane.

Seems like since the new UI, that for some feeds the original choice just displays a blank white area… Now I have to click out to the site. Very frustrating!!