Open pages in the background instead of foreground

At the moment each time I click on the feed title my (regardless: only with mouse click or popular shortcut CTRL + mouse click) the page opens in a new tab in the foreground.

It is often handy to have it opened in the background for a later reading and continue browsing the posts.

Of course I can switch back to NewsBlur manually but it takes time & additional clicks so such improvement would be convenient. Please consider implementing it!


Try clicking on the title using the mouse wheel. Works for me.

It would be very helpful if an option is added.

When using “o” to open the article in Safari it works. But not on Chrome. So this is probably a browser compatibility problem.

For Firefox, go to about:config, find
Set it to true.

You also want to increase
if you are opening lots of tabs like me.

That’s only necessary for use ‘o’ to open pages though. If you use mouse, you can just use the mouse wheel to click the link. It will open new tabs in background for any browsers.

1 Like

wow! That did it for me. It works perfect now! Thanks a million.

If you want to do this with the keyboard in Chrome, I created an extension to fix this problem. I haven’t really tested too many scenarios, but it works for me. The extension sets the “;” key to open the current story in a background tab.…

If I get any feedback, I’ll look into getting it into the Chrome Web Store this weekend to simplify installation.


Most browsers allow you to set this as an option (open new tab in background) when clicking links so not sure it should do it on newsblur (or it may annoy people that have set the behaviour they want in browser).

I use the middle mouse button and it’s still the same effort of one mouse lick.

Nice extension. I’ve sent you a pull request that fixed a problem with my italian keyboard.

I like using keyboard shortcuts, e.g. o, j, k, etc. so the option to have a shortcut to do this would be quite handy.

The middle mouse button works indeed as long as you don’t have it assigned to other function (as I do)…

The other thing is that I do not want to change my browser default behavior since I enjoy it in all areas but the RSS reader. Please take Google Reader example re: this particular feature :wink:

1 Like

I really hope this works out! For now, when I try loading the unpacked extension, I get this error:

Could not load extension from ‘/Users//Downloads/Newsblur’. Manifest is not valid JSON. Line: 4, column: 2, Unexpected token.

How might you recommend I fix this?