Newsletters not showing up

#1

It seems my newsletters haven’t been updating since sometime yesterday late afternoon. My exim logs show emails being successfully forwarded to newsblur, but there’s nothing new in my Newsletters folder since 4:15pm yesterday.

1 Like
#2

Same issue here, too.

#3

Add me to the list… Noticed it yesterday, no new forwarded emails in the past day or so…

#4

Yep, I borked it yesterday when I updated the SSL certificates. Looks like mailgun can’t connect to the newsletter server. Fixing it now…

#5

Oh boy that took a while. It is now fixed and you should see your newsletters come in. I believe some of them were dropped, but any that were sent in the past few hours should still show up. It’s a new feature and this is the first outage. But it shouldn’t happen again as I now have a new procedure for setting up SSL certificates.

#6

Yep, I see a couple have now made it through. Thanks!

#7

System administration is dark and full of terrors… There is however, a bit of light 

#8

Same problem. About 1 of 3 of my newsletter subscriptions is making it through and then all that makes it through is a “begin forward message” line of text and then nothing. Even

#9

Hey Kevin, I’m glad you got the feature setup. Any newsletter sent after August 12th should be showing up. I checked my logs and see only one email for you, the one you forward to yourself on August 12th. Check to make sure the email you are having GMail forward messages to is ‘Smokler-XXXXXXX@newsletters.newsblur.com’. I’ll see it in my email router’s logs if it’s sent to that address. But it looks like they are not forwarding correctly yet.

#10

Sam, 

I’m not forwarding from gmail. I’m forwarding from Apple Mail. 

I basically sent up a rule in Apple Mail that say, anything set from the NextDraft Newsletter’s email address would forward to Smokler-e8f6defa8d2c@newsletters.news…

Have I done this correctly? 

–Kevin

#11

Oh no, don’t post that email address! Now anybody can send you email directly to NewsBlur. (Not the worst thing, I guess).

That should work, but I don’t see any newsletters being forwarded for you in my email routing logs.

#12

Ok I will give this another go. 

#13

Seems to be happening again since yesterday. My exim logs show the newsletters getting forwarded to newsblur successfully, but they’re not showing up on the site. Hopefully it’s just another certificate expiring after a year :slight_smile:

1 Like
#14

It’s happening since yesterday for me too!

#15

New newsletter mail 30min ago still doesn’t show up in NewsBlur. Last known working date: sept 09

1 Like
#16

I’m also seeing this since yesterday; I’m forwarding via Gmail and the filter seems to work.

#17

Looks like the SSL certificate expired on the newsletters machine. I renewed it last week but forgot to update it on that server. I’ll change the SSL refresh deployment script to fix this.

#18

Turns out my fix this morning didn’t work correctly. I just put in a real fix that I verified on my end. Hopefully it now works from Mailgun’s end.

#19

Seems to work again

#20

Yep, I’m seeing newsletters coming in as of around 3:30am this morning eastern time. Thanks!