new android app version (4.8) crashes after refreshing stories

Newsblur 4.8 stops soon after start. 4.7.1 worked well.

1 Like

Same for me on Android 6.0.1 running everything through tor.  Downgraded.

What’re your usernames? We can take a look today.

strugk

If you do get any problems in Beta, please do report the crashes via your device; this is incredibly helpful for us in tracking down problems with the upgrade process.

it want beta and i am not sure what do you mean by ‘reporting via’. In case getSatisfaction probes commenting devices I wrote this using device in question.

When an app installed via the Google Play Store crashes, the resulting pop-up window should offer a little “report” button if you are on a standard device (though some manufacturers remove this).  After tapping through a few screens about what data will be sent, this sends us the raw crash and lets us help you out.

With luck, someone else who has seen the crash will get a chance to send it in and we can tidy things up asap.

Ah. No PlayStore in my phone. F-droid only - maybe that will be a hint.

Ah, there we go.  F-droid doesn’t allow us to get crash data, for privacy reasons.  Let me double-check the version up there just to ensure it matches the one available via Google.

Ah-hah! It looks like a bad build of v4.8.0 was pushed to F-Droid.  I will try and track down how to fix that.  In the mean time, the version available via Google (or a custom build, if you are extraordinarily enterprising about open source!) should work fine.

If you want to build it yourself, it’s quite simple. There are installation instructions here: https://github.com/samuelclay/NewsBlur/blob/master/clients/android/NewsBlur/BUILDING.md

And the only dependencies are vendored, so you don’t have to do any work to get it running.

I install the app from F-Droid, and I had the same issue.
Uninstalling and reinstalling the app “fixed” this, since the latest version available on F-Droid is now 4.7.1, which appears not to crash.

Yeah, I had the F-Droid folks pull their bad build of 4.8.0, and am working with them to get good builds flowing there again.  Turns out we were getting a bit lucky in how our builds there worked at all with their very specific system, so we might need to tweak a few things to get them up and running again reliably.

Thanks for update!
Good Luck!

New 4.8.0 arrived at F-Droid and works well.
Cheers!

Glad to hear it!  Just FYI, due to the build hiccough, the version of 4.8.0 up on F-droid may have had some experimental new features leak into it. ;)  It is probably best to treat 4.8.0 as a beta if you encounter any issues!

After upgrading to 4.8.1b2 (F-Droid build), the app crashes as soon as I launch it. Same behaviour in the previous version. Once again, the uninstall-reinstall workaround seems to work.

Please keep working together with the F-Droid team, it’d be great to avoid such issues in the future.

Just looked at the 4.8.1b2 build on F-Droid and it looks clean.  If you got an on-upgrade crash, it is probably a new issue.  Unfortunately, F-Droid doesn’t let us see your crashes, so anyone testing the Betas via them will need to find other ways to get us crash logs in order for us to diagnose.

Just upgraded via F-Droid and I experienced no issues with upgrade and running the app.