JSON feed without home_page_url silently fails

Per the JSON feed spec, the only required fields at the top level are version and title. I’ve finally figured out why some of my feeds fail on Newsblur- they don’t have a home_page_url, and Newsblur will silently fail rather than showing the feed title and the items.

Here are some near-minimum test cases.

‘with url’

‘without url’, shows [untitled] for the feed title.

Without going through the rest of the code, I assume it fails because of None here, rather than a valid string. I’m still trying to test what is required for the items array but I’ll have to wait more hours before I can get it to refresh.

You have got some epic timing. I just came back from a week long vacation and have the newsblur code up.

Just fixed it and deployed the fix. Hit insta-fetch or wait for it to come in, it should work now. Thanks for writing this up!

oh nice! I was creating some new feeds and finally dug into what was causing it.

Further testing, look at the feed examples again. I tried adding to items an item that doesn’t have a date_published, and I believe that causes an error, Not an RSS feed (553).

noting for myself (since I end up googling and finding this occasionally), a null id in an item will give a 553 too. Maybe also url but I haven’t tested that.