Full Ars Technica Feeds hidden behind "full Text view" banner


#1

I’m a subscriber with Ars Technica which includes access to RSS feeds that contain the entire text of the article (as opposed to their non-subscriber feeds which just include a couple of paragraphs and a link to read more).

Up until recently these feeds worked fine in NewsBlur on mobile (iOS on iPhone X) where I could read the entire text of the article as normal, however lately most of the article text isn’t displayed and it says “The full Text view is a premium feature” at the bottom, similar to what used to happen when I was on the non-subscriber feed for Ars.

The hiding of the article text isn’t particularly consistent, sometimes it doesn’t happen and I can read the article fine. Anecdotally it appears that the banner blocks the text when I load the article with a working internet connection, but not sure if that’s consistent.


#2

I believe your account reverted to free, in that case. The message is a callout to upgrade to premium.

Otherwise, share with me the newsblur.com url of the Ars feed. Here’s a couple that may be different (they have different feed addresses).

http://www.newsblur.com/site/6232309/ars-technica

http://www.newsblur.com/site/2317871/ars-technica


#3

If you’re talking about my NewsBlur account reverting to free, I’ve never paid for one, so don’t think it would have reverted.

Is there a way I can share the feed URL with you privately? From what I can tell sharing the feed URL means the feed is readable publicly by everyone, and this is a paid-for feed that isn’t supposed to be shared.

In the examples you have you’ll note that at the bottom of most articles there’s a “Read X remaining paragraphs” link that the pay-for feeds don’t have, but presumably the feed still gets flagged as a Full Text View feed by NewsBlur and draws the banner.

Is there a way to just disable that feature completely so that it doesn’t try and draw a banner on any feed I have?


#4

Feeds don’t get flagged for full text, you have to explicitly select the Text view. Try switching between Feed/Text/Story at the bottom. That way you can switch back to the original feed, which has the full text.


#5

Works perfectly, hadn’t even noticed that option, thanks!