Explosm (Cyanide & Happiness) feed view broken

The feed http://feeds.feedburner.com/Explosm from the website url http://www.explosm.net/rss.php is not working optimally.
Setting the view to “feed” will just show the message “New Cyanide and Happiness Comic” for every entry in the feed. This is my prefered view, and would like for just the comic to show up (Just like the XKCD feed).
Setting the view to “original” just leaves a blank page and setting it to “story” just messes up all the images and I have to scroll down to see the comic (not very pretty).

Is there anything that can be done with this feed?


I subscribe to Cyanide & Happiness with Story mode and have no problems, including this morning’s comic.
I’m using the latest Chrome browser.

This is my story view. it might have something to do with having the https option being enabled. But it’s still broken as you can see. And it would be nice if the “feed” view can be changed to only show the comic, just like with XKCD.

Yeah, it’s because you’re on https. I recommend going to the site directly to cache the resources, then https might look OK for a while, as the CSS and images are cached. But the real answer is to enable mixed content (click the lock next to the URL in your browser).

When you say “enable mixed content”. What exactly do you mean?
These are the options I am given:

Try following this guide to enable mixed content in chrome: http://wiki.sln.suny.edu/display/SLNKB/Enabling+mixed+content+in+Google+Chrome

That helped. Thanks very much.

Is it possible to make the feed view have just the comic, like on the XKCD feed?

That would be up to the publisher. Knowing their history, I don’t think they’ll be adding the comic to the feed.

There is probably a Yahoo Pipes feed with the comic, just have to find it. If not, it’s probably not overly difficult to create one yourself. Someone did that for Dilbert.