Does anyone know why this feed isn't being added properly in newsblur?

This feed seems to be added to Newsblur, but the site added will say “untitled” and have no entries in it, and as soon as I click on another site, it disappears. 

Same problem with this feed

Anyone know why?

1 Like

It seems, It’s not a valid feed :

1 Like

hmmm interesting. Its not even getting to the feed. its failing at the ssl level with

Server returned [Errno 1] _ssl.c:504: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

I’m also getting it from the commandline using wget, but not with curl, which leads me to believe it might be an issue with the ssl configuration on newsblur’s servers

I’ll do some more digging.

it looks like with the feed validator is trying to connect using SSL3 when its a TLS 1.2 https site

Ok, there are enough SNI complaints out there that I’m convinced I have to do something before Ubuntu releases support. This requires a huge change to the backend, as I have to start using virtualenv and rewrite how celery and gunicorn work. This is going to take some time but it is now being worked on.

1 Like

Can’t you just disable certificate validation?

Or if TLS support is the issue, use an SSL proxy to decrypt it?

It seems like this should be something that can be solved in the network.