Command/ctrl-click doesn't respect open in new tab settings

If you command/ctrl (depending on platform) click on a link in a newsblur story, it should respect your browser’s settings for whether to open that link in a tab in front of / behind the current one. It feels like currently newsblur is hooking all click events and applying its own target to the link first.

Easy fix is generally to check whether a modifier is being held down in the click handler and just not do anything in that case.


Though I do note that middle-click works fine. Alas, this doesn’t help much when on my laptop.

1 Like

You can change this behavior in NewBlur’s settings. Just click the gear icon in the lower left of your screen and click Preferences. Then click on the Stories tab and change the “Open links” setting to your preference. Enjoy!

That setting doesn’t actually change this behavior – it’s for unmodified clicks.

Try ctrl/command-clicking a link in this window. Unless you’ve changed your browser default settings, it should open in the background.

Then try doing the same in a story on newsblur. It’ll open in the foreground, switching focus from newsblur.

Command-click for me opens all links on Newsblur in the background - both stories itself and links within the stories.

Interesting! I wonder what’s different about our experiences.

Aha! It works properly in Chrome, and behaves as I see it in Firefox.

I’m using Safari, and it’s working for me.

I’d hypothesize that it’s “works in Webkit”, then.

I can confirm that this bug still affects Firefox 21, but it works properly in Safari 6.0.4. I am running OSX 10.7.5.
I just started using NewsBlur and it seems like a great replacement for Google Reader!
Fixing this bug would make it perfect!