Chrome Freezes (on Windows)

I’ve recently noticed that newsblur is slowing down Chrome (and Windows) to a halt. When I’ve had only one window open (with two tabs), I have been able to shut down chrome. Once shutdown, the operating system goes back to behaving normally.

I don’t know if the bug is in newsblur, the browser or the feeds that I have subscribe to (which may contain Flash). However, I have only experienced this problem over the last three weeks and newsblur has always been open in Chrome when this has occurred.

If it helps, the feeds that I’ve subscribed to are: Ars Technica, Buzzfeed, Hackernews, Nextweb, Techcrunch, Slashdot and Engadget. I highly doubt that the feeds are causing the issues, but there is always a possibility.


Hey, do me a favor and check if any of those feeds have audio enclosures (embedded mp3s). I just want to see if those are the culprit. If so, I have a great solution.

I was experiencing this problem a week or two ago as well, though it seems to have gone away since I installed some new hardware and reformatted. I’m pretty sure none of my feeds have audio enclosures.

Sorry, no audio enclosures :frowning:

I too have this problem. The weird thing is, it isn’t always the newsblur tab itself, but occasionally the tab I open by clicking on the story headline. whichever it is, the tab’s process spike to 25% CPU and everything grinds to a halt. I can generally kill the single tab process and reopen newsblur/artcile.

Don’t think it’s ever had audio enclosures, not mp3s at any rate. maybe flash?

Just pushed out a fix (last night, actually) that hopefully fixes this issue. It turns out there was a Chrome-specific jQuery bug in 1.6.1 that was resolved in the latest 1.7.1 release. Let me know if everything works smoothly now.

1 Like

Thanks as always for the awesome support

I still seem to be having this issue. I haven’t narrowed down the repro steps yet, but it happens while I’m going through feeds, reading some in-line, some with the NewsBlur views, and opening some in new tabs.

I’ve got Chrome 16 running on Windows Server 2008 R2. When the issue occurs, my whole machine grinds to a halt to the point where my mouse moves in jumps every second or two and pressing Ctrl+Alt+Del takes a minute to respond if it even does. Sometimes I can get out of it by hitting the power button a few times to make Windows start shutting down which sometimes kills the right process to give me control and then I can cancel the shutdown.

This is still occurring for me as well. Originally I thought it was triggered when I opened a story by clicking on the headline, but just now my newsblur tab froze up without any other tabs open.

Chrome 16 on Windows 7.

Let me know if I can give you any other info.

This has just started happening to me again, after it seemed to have been solved for quite some time. When I click on a feed, my entire computer will occasionally lock up, forcing me to do a hard restart. I’m using Chrome 16 on Windows 7.

Yeah it’s back for me as well. I’ve stopped using NewsBlur as much because of Chrome’s propensity to lockup when I load my feeds. I’ve added more feeds than I had so perhaps that’s it.

This has been discussed today on Twitter as well. Chrome just released a week ago—version 18. Just to confirm with everybody here, is this a Windows bug for everybody? I’ve got you Hanoran, and then @aeoth and @northirid confirming Windows as well. Is there any conceivable way to reproduce it reliably? If I want to fix it, I’m going to need to make it happen a few times so I can tell if I fixed it (and to figure out exactly what’s causing it).

I’ve only had it happen on Windows, but I very rarely use NewsBlur on anything but windows. Since it’s come back, it’s only happened specifically when I click to load a new feed. I’ll post here again if anything changes.

My Chrome installation lists 16.0.912.77 as it’s version number. I’m on the stable channel.

My Chrome is 16.0.912.77 too.

I get a total system destroying hang on an almost daily basis using Chrome on Windows. I don’t use Windows at home, but then I don’t tend to read feeds on anything other than my iPhone at home (until we get iPad NewsBlur).

I got to the point where I’d started writing my own Windows client to try to work around the problem!

I have no feeds with enclosures. It MIGHT be related to opening stories in new tabs in order to read them later. Does anyone else do that?

So my workflow is scan feeds in NewsBlur, and anything that looks like it’s worth reading I middle click to open in a new tab. I’ve noticed that when I do this, the new tabs are listed in Chrome’s Task Manager as being under the NewsBlur App. Could this be related?

I’m pretty sure I’ve had it happen a few times when I’ve had no other NewsBlur tabs open. I tend to follow a similar workflow, but it’s happened before I’ve had the chance to open any stories.

So far, I’ve noticed that only using the Everything view seems to be a workaround. I’ve yet to have it crash when opening that view, while it still seems to crash relatively often when loading individual feeds.

Do you ever load the Original view? Because if not, then opening a feed is no different than opening Everything. I’m thinking it might have something to do with garbage collection, but I doubt that. When I create DOM elements, I use delegation, so no DOM nodes should have an event tied to them that would prevent GC by Chrome.

Crashes for me in everything view (it’s the one I use most often). I don’t use original view 99.9% of the time, and I haven’t noticed it being tied into the crashes.

I only use the Feed view. Maybe I’ve just gotten lucky with Everything view so far, it seems like others have had it crash in Everything view as well.

This just happened to me again, twice within an hour! Windows7 and all open applications grind to a halt and stay that way until I finally manage to get the newsblur tab closed. Then it all springs back to life.

I never use everything view, all my feeds are kept in feed view and if it’s necessary, I open the story by clicking on the headline. I sometimes feel that this is the event that triggers the issue but cannot be sure.

Is there anything I can be trying to capture that would be useful to you? It happens regularly enough now I feel I should be doing something to help!