can't subscribe to flickr "Recent Activity" feed.

If you go to and scroll down their is a link to an RSS feed. Looks like this:…

In my case the URL is readable by Firefox for example but when I try and subscribe via the newsblur web interface I get the error “This address does not point to an RSS feed or a website with an RSS feed.”. I also get a popup list that suggests other people’s flickr feeds (for uploads, comments, etc.).

1 Like

I ran into an issue with this (which I didn’t report, because I eventually worked around it) where NewsBlur was turning %2b into + — you might see if that happened.

Do you mean that Newsblur is treating %2b as a urlencoded + sign (i.e. a space)? How can I work around that, by further percent encoding the percent encoded plus ?

tried that, didn’t work.

Somebody somewhere is double encoding, but I don’t think it’s NewsBlur. You just need to pass the raw URL, but Flickr might be encoding it for display.

So, there was indeed something suspicious about the URL:
When hovering over the link on the flickr page I see a URL which has unencoded special characters, specifically @, + and =. When copying or clicking this link in Firefox my clipboard or address bar respectively contains the URL with only the plus and the equals sign percent encoded.

With this I thought that I had found the problem, however even if I encode the @ sign as %40 so that the URL query args are properly encoded still Newsblur doesn’t accept the URL. Loading the URL in Firefox or in Chrome brings up the RSS document as expected.

Another thing that is suspicious, and happens only in Firefox, not in Chrome, is the following: after copying the RSS url from the address bar I go to Newsblur and click on the button in the lower left to add a new feed (+). The popup shows up and he text input element is focused so I can just press Control-V on my keyboard to paste the feed URL. After half a second a list of feeds of appears above the text input element. Nothing else happens but the minute I move my mouse pointer even slightly the URL in the text input element is substituted with another URL from the feed list, with the corresponding list entry getting highlighted. This happens despite the fact that the pointer doesn’t go near the list.

Here’s what I see before and after I move the pointer:

Additionally one of the URL’s that appears in the list is the URL of the deprecated flickr activity RSS feed that I had once added to Newsblur (it’s the second in the list). If I select this feed and hit the submit button then the feed it is succesfully added to Newsblur, although it doesn’t contain any data (only a “self-deprecating” placeholder article). Strangely Newsblur says that this deprecated feed has 71 subscribers. I wonder if there are really 71 people who are interested in reading the comments off my flickr page :slight_smile:

And while I’m at it here’s a screenshot of the error itself: