Can't import from Google Reader

Like many others, I’m leaving Google Reader and I remembered that I had a NewsBlur account from a while ago when I had tried it. Sure enough, I logged in and had a few feeds that I didn’t really want. So I deleted them all.

Now when I click add sites and choose “Import from Google Reader”, it asks me to grant access to my google account and then it redirects back to and prompts me for a new username, password and email to create a new account!

If I give it my current username/password, it just says that user already exists.


I’m willing to bet dollars to doughnuts that you originally went to and then ended up returning to, thereby losing your cookie.

There are a couple possible solutions to this:

  1. I should fix that damn cookie so it works on all subdomains. Not entirely sure how, but I’ll figure it out
  2. I should fix the server so that it redirects all non-www traffic to www.

In the mean-time, what you can do is go to and login there. To import from Google Reader, simply click the Add button in the lower left. Then you should already be logged in. Hope that helps and let me know if it goes according to plan. But I’m going to fix that permanently for everybody else.


Yup. That worked. Thanks.

FWIW, I’d have a preference for redirecting all traffic to The www isn’t adding much other than the except 4 characters in the URL.

Tried your instructions. I’m on www and importing. Make sure to return to www and still nothing. I have folders but no content.