Cannot log in, too long timeout!

Since yesterday, I cannot get my podcasts because Newsblur does not respond to open the page! I wish I had saved my podcasts so I can still get them!!

We switched hosting providers yesterday, so you may have to ensure that you can reach the new hosting provider. What do you see? Are you able to login on

YES! I thought I’d have to go through every single podcast and try to find them again. Now I want to download the whole list so I don’t have to freak out like this ever again. I wish we had been warned this would happen.
Should I tag this website now to make it work? And I might have tried to change my password to get in. I hope this will continue to work.

Thank heaven I could still manage to find the newsbur forum!

You shouldn’t rely on, since I’m going to be taking it down at the end of the week. Let’s figure out why isn’t loading for you. I changed DNS, so it’s pointing to a new machine. What do you see when you load

I get nothing but a blank page and then –

This site can’t be reached took too long to respond.


  • Checking the connection


Does load better for you?

Yes it was faster and works on my phone too.

Please remind me how to export all my podcasts for me to keep them. I can’t imagine trying to find them all again!

settings > account > download OPML button

(which is a good idea anyway! the site is nice enough to email you one if you delete a lot of feeds at once, just in case you didn’t mean it.)

I am having the same troubles too. Regular newsblur com and the mobile app aren’t connecting but both of the special websites open right up

Have you restarted your devices? I’d love to know if that fixes it. It shouldn’t be a DNS issue even though it changed because the old server still works (dwww) and the new server clearly does too (hwww).

Sorry, I’m still having the same problems on my phone.
When I get home, I’ll have to try it on Wifi. Also I’ll try it on my PC

Alright, I’m pretty sure that it’s my phone’s data that is my problem. When I connect to wifi, I don’t have any problems, through my phone’s browser or the app. The PC works just fine.

To answer your question – Exact same problem after rebooting. No help at all.

The link does work fine though.

1 Like

I forgot to confirm that after rebooting, the link works great too. The regular link continues to time out.

It works now from Thanks

It worked a couple times, but not this morning…

Ok, I believe it was due to a faulty IPv6 DNS entry. I removed it and it should propagate within the hour and you should be seeing fast speeds again soon. Let me know if that resolves it!

I can confirm that it now works in testing. Let me know how that goes!