Auto-playing videos in feed view

I’ve got an annoying problem with the Splitsider feed (, where it will auto-play videos before I get to them, as NewsBlur loads stories ahead of where I’m reading. This happens mostly (entirely?) with Comedy Central videos, and is incredibly irritating when they post about several clips in a row, as I end up with a bunch of Jon Stewart or Stephen Colbert clones yelling at me while I’m frantically trying to find them to shut them up.

Is there a way to disable the auto-play of videos in the feed view? I’ve tried a couple flash blocking extensions, but they tend to either not work or mangle the feed, leaving a blank space where the video ought to be, which means that I’ve got to click through if I actually want to watch, rather than being able to watch in the feed.

Thanks! You’re doing a great job, keep it up!


If you’re on chrome, you can go to settings -> advanced -> privacy -> content settings -> plugins -> manage exceptions and add set to “ask”.

It should then have all flash stuff require you to click it before it will load.

That doesn’t help. I think Comedy Central videos are HTML5 and not “plugins” per se, so this doesn’t help.

(I’ve had plugins set to ask for all sites for years, still, CC videos autoplay on feeds)

Also the videos start playing even if they’re hidden (reading in focus mode), which makes it extra annoying…