Annoying animation when navigating with J/K

When navigating through stories on the list view, in some cases the scroll animation goes to the top of the page before scrolling to the desired story.

It doesn’t happen in all situations. I observed it while scrolling ‘only unread’ stories and also on my saved stories.

Not a big deal, but all the jumping around gets old really fast.


I would turn off animations in that case. I think what you’re describing is the normal behavior. When you read a long story, then click on the next story, the previous story has to collapse first, jerking you back upwards.

Good point, didn’t remember I had this option. This fixed my problem.

About being normal behaviour, when I select the option to view ‘all stories’ this doesn’t happen, so I still think there is something wrong going on here. I recorded a video to show the problem:

Yep, that’s actually how it’s supposed to work. It’s not ideal but I haven’t figured out a better way to do it.

1 Like