Android: read and marked as read reappeared

As usual I was looking through my all stories list of items. I read an article on my xkcd feed, returned to the all stories screen, then marked above as read down to GSM arena article on Sony Xperia and stagefright. They all went away, then the screen flickered and they reappeared. Even the story I had actually read. I took a screen shot at that point and have attached it.

app version: 4.6.0b1
android version: 4.4.2
device: samsung SM-T700 (universal5420)
sqlite version: 3.7.11
username: JimB
memory: normal
speed: 38 feeds in conn:896 read:7 parse:121 store:105
premium: yes
prefetch: yes
keepread: no

1 Like

Hmm, sounds like (, but I had hoped we had fixed it in this Beta.

Try this: next time it happens, rotate your device or go back to the feed list and immediately return to that folder.  Do the stories then appear correctly marked?

Yes it does.  He didn’t say much initially so I was not sure what he meant. 

I did go back to the feed list and immediately returned to the All Stories list; they were wrongly marked.  I don’t normally have rotation enabled, so I will try that next time.

It has just done it again. I have tried rotation, and I’ve tried going back to the feed list. Neither has changed the marking to match what I had marked as read.

Thanks for bearing with this.

Are you marking read by tapping into the story, or using one of the long-press mark options? If the latter, which one?

If you have a tab open on a computer, do the unread counts immediately update in cases when the app fails to do so?

When the app does fail to update the status of stories, what does eventually update them? Going all the way back to the feed list? Refreshing? Killing the app? Rebooting? Waiting a particular amount of time?

Thanks for trying to help.

If I am actually reading a story, I tap into it.  Otherwise I long press and tap on “Mark Older as read”.  In the Android app, the actually read story stays put, the marked as read ones disppear. 

I must say I preferred it when the marked as read stories stayed, but just greyed out.  That still happens in the Windows web browser.  It is far better when you realise that the next story you were just about to read was actually the same time as the one you’ve long pressed on, because they both disappeared.

In general, that means I mark up to the last story on a page each time, so that the first unread story jumps to the top of the page.  Otherwise I have to scroll to get to the first unread.  In any event, I have to scroll to get the actually read articles right up to the top of the page to be able to see more unread ones.

If I have the tab open, and on my Android  “Mark older as read”, the left column with the feed names flashes on the feeds that have been bulk marked as read, and the unread count against each feed name updates accordingly.  Nothing happens in the tab if on the Android I actually read a single story, or If I long press a story and tap “Mark as read”. No action on my tablet updates the right window of the story list in the web tab.

When the app appears to update, the stories go away only to return a few seconds later (it hasn’t happened tonight, but happened once this morning i.e. Friday) I generally get the most recent batch of “Mark older as read” items back. Actually read items stay as actually read, and end up within the others that are bold.  Usually they reappear after a few seconds - occasionally when I return from reading a story that grabbed my eye.  I’ve not known it happen more than a few seconds after marking, unless within that time I have actually read a story.

NB I have not been near my PC to investigate this when the stories return. 

If I again “Mark older…” they usually go away permanently.  However, on occasion when I’ve got fed up with the most recent stories reappearing, I have done the mark older… and then immediately returned to the summary screen; that has never left any marked as read showing as unread.

I had three new stories and tapped on the tick near the top right . I OKed the dialogue to mark the entire feed as read.  That has NOT updated the unread counts in the web tab on my PC.  My tablet still shows no stories to read.  Refreshing the web tab has cleared all the stories.

I hope this all makes some sort of sense.


Well. Last night I read all the stories outstanding. This was confirmed on my tablet and Windows PC. This morning there were 25 new stories, so clearly the marking from the night before appeared to have stuck. I read them too, on my tablet. This afternoon there are 330 unread stories (I first looked on my phone, was horrified so checked tablet and PC) . Every one I had marked has reappeared., back to 5th November (it is now 7th). Is there an issue with using the app on both a tablet and a phone?

I have also had problems with newsblur stopping.

This issue of items bulk marked as read reappearing a few seconds later is still happening. It is not every time, it is not always all of the stories just bulk marked. This morning, it worked fine for the first groups marked, a page at s time, totaling perhaps 40 items. Then a group of 13 reappeared shortly after marking. I marked them again, and they reappeared. I marked them again, and 3 reappeared. Finally, they all stayed marked.

Newsblur Android has not been stopping since my previous post.

I’m not sure how the beta program works but having been on 4.6.0b1 I’m now back to 4.6.0.

This is still happening. Most of the time everything works well but at some point in most days a bunch of previously marked stories reappear. Sometimes that happens in two or three bursts, which I notice as what I’m trying to read jumps around the screen. Today I noticed that even some stories I had actually read (rather than just marked) also reappeared. I cannot be absolutely certain, but there did appear to be one of two additional stories that I didn’t recall having seen as I’d read the headlines before making as read.
It isn’t feasible to either return to the main page, or to rotate the screen after every marking as read. I’d look like a demented fool, and when I tried it felt I was playing some weird game. As it doesn’t happen every time, every day, or with any regularity how can you tell if it was the rotation that had any impact? Unless I mark them in screen by screen batches, I then have to scroll back and forth to get to the earliest unread. (I do wish you’d left that alone and left it so that “read” stories just greyed out, but you had to improve it) Doing so once the stories have reappeared is utterly useless.
Somehow, my newsblur is again showing 4.6.0b1. I do not understand the logic of numbering, as I’ve been on this previously then lost the b1 and now back to it. I’m on auto update.

Have you had a chance to try 4.6.1b1? It contains my best crack at fixing this despite the fact that I haven’t been able to reproduce the problem myself.  Some feedback as to improvements or lack thereof will be very informative!

As I return to newsblur this evening, it is showing 4.6.1b1.ill report back idc

All yesterday it worked perfectly. Today, it worked the first twice of marking, but the third time it brought back 6 stories, showing them as unread, including one I had actually read rather than marked (techradar story about audi). So I came here to report. However, when I returned to newsblur to count the number of stories that reappeared, they had gone. I’ve screenshots of immediately after they returned, and the minute or so later when they had reappeared. All I did was go to Outlook for the email advising of your last response, open the link in Firefox and start typing, then use the task switcher to return to newsblur.
In the past, I’ve carried on reading newer articles and the returned articles never re-disappeared.
I’ll keep an eye on it.

A bunch or read and marked as read stories just reappeared, but this time 3 stories that were not there before.

Oh that’s weird. It has just done it again. Two of bbc stories appearing as well as read ones. I scroll down to where I’d got to before, and the screen twitches and some more read stories reappear. Scroll down, and more again reappear.
83 in total, and the two stories that I have only just actually read now show as unread.
Finally they’ve all stayed read.

No problem yesterday. All read items stayed read.
Today, back to the same.
Also, the “User not subscribed” pop up appeared twice.

And it starts again

If these problems have persisted across so many versions of the app, it is sounding more and more like there is something odd about this particular device or the Samsung-customised version of Android that it runs.  If the next Beta release doesn’t totally fix it, I think I am going to have to try and track down one of these tablets to see why it behaves differently than all of the hundreds of other devices we run on.  This is the Samsung Galaxy Tab S 8.4, yeah?

Yeah that’s right.  Samsung Galaxy Tab S running Android 4.4.2, rooted.  Occasionally if I go back to the home screen, and return to the “All Stories” view, thse marked ones disappear, but more often than not they don’t.  In another thread, Samuel has suggested that the next beta version might help as it updates teh database system.  Thinking about it,

I’ll be curious to see if the Beta helps.  To be perfectly candid, we haven’t done anything that would necessarily affect the issues you are seeing, but we might get lucky.  This sounds more and more like the device has a network or storage system that, if not faulty, works very differently than stock Android.

Is there any particular reason you haven’t upgraded past 4.4.2? Has that device stopped being supported by Samsung?  Also, do you have any way to try the NewsBlur app on it after flashing a non-rooted image? (rooted or custom ROMs really shouldn’t be a problem, but sometimes they mess with system components in undocumented ways)

The beta has fixed the problem. So far, there has not been a single issue of a previously read article ungreying itself.   It also syncs pretty much  immediately with my phone and laptop.  I like now that the app works the same way as the web page, in that the “Marked as Read” items do not disappear until you return to the summary screen and back to the All Stories view, they just get greyed out.  This is how it started and what to me worked best.  It also means if you notice a headline as you are touching the mark as read button, you can still read that article.  Even better, if I touch the mark newer as read button instead of the mark older (it happens too often - see separate post!), at least it has not removed those articles from screen, though I won’t be able to refresh that device till I have read them all.

Samsung in their infinite wisdom have stuck on 4.4.2 for the Galaxy Tab S.    They do not have a good record of updating even flagship devices beyond a few months after release.  Lollipop was released long before the Tab S was replaced by the S2.

Sorry but I have spent a long time setting up my device as it is and running well, so I am not going to play around with flashing a stock ROM.