Android: broken images served through image proxy

#1

One of my feeds doesn’t show images – I only see broken images. I think it’s the image proxy newsblur uses in the Android app, and an update of imageproxy might fix it.

Some more detail:
The images render on the web (both story and story list), and they also render on Android in the story list – just not in the actual story.

Problem feed: http://feeds.feedburner.com/SlickdealsnetFP

After some poking, I discovered it’s not the android app, it’s the imageproxy it uses (or maybe it’s how the android app is using the imageproxy).

A broken image URL is:
https://imageproxy.newsblur.com/sc,sfV7x-oW8XAKoynnZDw8yJBPZAIOIH8HSIcs-67sJ5ag=/https:/static.slickdealscdn.com/attachment/2/3/3/3/7/5/2/0/200x200/9367124.thumb

The original image URL from the feed is https://static.slickdealscdn.com/attachment//1/7/4/6/2/3/4/200x200/9366914.thumb

The proxy request returns the error “requested URL is not allowed”.

I noticed some imageproxy bugs on calculating signatures for URLs with double slashes, which the original URL has.

Dunno if that’s a red herring, but it sounded plausible, especially if newsblur is still running an older version of imageproxy (the bugs I found were fixed in 0.10).

It might also be helpful to look at the server logs, it should give more context on what’s happening and why the request is returning a 403.

Alternatively-alternatively, is there a way to disable imageproxy? (My guess is no.)

app version: 10.1b5
android version: 11 (RP1A.201005.005)
device: Google Pixel 4a (sunfish)
sqlite version: 3.28.0
username: eviljim
server: default
speed: 155 feeds in conn:1034 read:103 parse:61 store:13
pending actions: pre:0 post:0
premium: yes
prefetch: yes
notifications: no
keepread: no
thumbs: yes

#2

Ok I looked into it and noticed the bug is clear on Android and not an issue on web and iOS. Here’s the ticket:

I’m already running the latest image proxy, so that’s not it (although it was a good guess). I’m not sure why it’s failing but honestly, https images shouldn’t be run through the image proxy. So I’m going to have it disabled on Android. Good thinking!