Android app won't log in

#1

Okay so the app got stuck loading stories, it’s happened before and either clearing the app cache or even the data will clear it up.

So I did that but then it wouldn’t let me log back in, so I uninstalled and reinstalled still won’t log in, I tried installing an older version… nope.

Out of curiosity I logged in on the website on my Android phone and it logs in just fine.

So I am completely stumped, the iOS version is fine, the mobile website is fine, just not the Android app. It’s the 10.1 version that got updated on 10/28/2020.

I also restarted my phone and it didn’t change anything.

I tried to cover all the bases before posting but it just doesn’t seem to want to work.

1 Like
#2

Same, cleared cache and data when no stories would load. Tried to login and couldn’t. Then somehow logged in and still no stories will load. It didn’t work on the beta, which I was on, or on the stable version to which I reverted.

#3

I have run into the exact same problem. Also tried reloading, cleaning cache, etc. Now can’t log into the app. Data is fine if I log in via web.

#4

I am having the same problem. I cleared the cache. I re-installed the app, disabled all of my phone security. It still won’t let me log in on android. Web and iOS are just fine.

#5

We’re looking into it and will have a fix out shortly. The first error we’ve seen is related to the ssl cert issue we had earlier but that was resolved after twenty minutes. Not sure why it would still show up as an issue.

#6

Ok, just pushed out a fix. Looks like I neglected to add in the intermediate certificates into the latest SSL cert. I need to automate the renewal but the problem is that it needs to go out to a bunch of servers and my orchestration tool (fabric) must be manually run. It’s a single command but it needs to be improved. Working on it for the Python 3 migration that’s nearly done.

#7

It worked, I can login on the Android app. Thank you Samuel for being on top of the fixes!

:tada:

1 Like
#8

Awesome, thanks for being so responsive!