Android App v2.1 Crashes on Startup

N4 with Stock Android 4.2.2

After I got the update to 2.1 Newsblur does not start anymore.

When doing a fresh install I can get to the Log In screen, but when I enter my credentials it also crashes.


Just released v2.1.1. Let me know if that works.

Same problem with 2.1.1

Try reinstalling the app. When did it work? Did you upgrade to v2.0 and it worked or is never worked at all?

What I did so far:

* normal update
* uninstall / reinstall
* uninstall /delete NewsBlurCash Folder/ Install again

all with the same result that the app crashes upon retrieving sites.

I was on v2 before that, which worked.

I can’t remember for sure, but I think the first time I ran 2.1 it crashed, but then worked fine after that. 2.1.1 though, crashes every time and won’t open. I’m on 4.2.2 as well but a galaxy nexus

From the crash report: (if i sent this in from the feedback app on the phone does it go to google or you?)

Exception class name: java.lang.NoClassDefFoundError
Source file:
Source class: com.newsblur.activity.Login
Source method: preferenceCheck
Line number: 40

I’m also on a nexus 4 and everything was working fine until the latest upgrade (now on 2.1.1). It crashes immediately on startup.


The crash “jason” is reporting happens to me as well. After ver. 2.1.1 was installed I cleared the app data and cache but the app breaks every time with the message “Unfortunately, NewsBlur has stopped”. This happens of 3 different devices - Nexus 4, Galaxy S2 and Nexus 7.



Can confirm that the 2.1.1 update is broken. If you haven’t udpated already, please wait a bit until we can get a new build out. We’ll push it as quickly as the app store will let us.

Oops. I installed 2.1.1 before I saw this (came here to see if anyone else was reporting the crash). Hope you get 2.1.2 in the market ASAP!

Same is happening to me. Newsblur 2.1 keeps crashing upon opening with the message “unfortunately newsblur has stopped.”

On my Evo 3D

Is there a way to uninstall only the most recent update?

I can report last night’s 2.1.1 update is force closing on startup. I’ve cleared the data/cache, etc.

F-droid supports previous versions unlike Google Play. Any chance of updating it more often?…

Yep, crashes my S2 as well, had worked perfectly up to that point. Great app as well.

Crashes on nexus 7 too. No problem before update. V2.1.0 on my phone still works.

The new version crashes for me too. Galaxy Y.

2.1.1 also crashes on the HTC one (Sprint version). Prior to last night’s update it worked fine.

Can you try side loading this apk:…

I just uploaded 2.1.2 to the Play Store, so it should be live in an hour for everybody.

1 Like