android app crashes on startup on a samsung s4 active / KitKat

i enter username and password, it thinks for a bit, and then gives me ‘unfortunately newsblur has stopped’ message, and shuts down.

new phone, new install of newsblur app, and everything else works ok, so not sure what is up.


Try using the beta android app. See… for details.

Samuel, I don’t use Google services, could you please make an apk file available for the latest beta android app? Also see…

Sure thing:…

1 Like

Sam, you seem to have also just silently updated the google play version to 4.0, which i assume supersedes the 4 beta you’ve uploaded here.
I went ahead and installed the one from google play, but it still crashes on me at sign in. how to troubleshoot this?
(and does 4 do offline/cache? which is really what i’m after while buzzing around the radio silent NYC subways)

You want this beta then.

Production still has v3.7.1. Beta is 4.0.0b4.

ok tried 4.0.0b4. it still crashes. i also tried entering ‘username’ (as requested by the app) vs my email address associated w newsblur, but then it said username not found or something to that effect.
something not right…

I’m having the same problem on a RAZR M. Tried beta and production versions.

I experienced this until I updated CM earlier. I believe it was caused by an SQLite update, which was reverted since it was causing some apps to crash:

Crashes for me too. All the time. Newsblur 4.0.0RC1, Android 4.1.1, no-name phone (rebranded Chinese stuff with MediaTek SoC and 512MB of RAM).

Getting this with both 3.7.1 and 4RC1, using Cyanogen M11…but it only happened after I cleared app data, and now can’t get it back

Also crashing on the cyanogen nightly from 10/13, so im not sure what that means for that sqlite issue referenced earlier

Sorry, spoke too soon…a second or third attempt to open the app leads to it working fine

4.0.0b4 installed from .apk file often crashing on Galaxy Nexus with Cyanogenmod.