Android app 3.5.5 now has restriction on Android version (> 3.0)?

I have a company phone which is ancient and can only run 2.x versions of Android. Despite this the Android app was installable and working well.

This morning I saw some comments that 3.5.5 was out and had fixed issues with previous 3.5 versions but when I went to force the update I could no longer see it in the Play store. Checking on the website of Play shows “Requires Android 3.0 and up” which must be new because all previous versions of the app were visibile and installable up till now.

Is this a hard requirement? Is there something in 3.5.5 that will definitely not work on Android 2.x?


This is a hard requirement for 3.5.5. It was the only way to fix some of the recent issues seen after rewriting the network stack.

3.5.4 is actually a rebuild of 3.0 to provide a final version that works on pre-3.0 devices.

1 Like

Got a link to an apk for those who missed upgrading to 3.5.4 before 3.5.5 was uploaded to Play?

Here’s the 3.5.4 (final releae for pre-3.0 devices) APK:…


Any way to get an even older version? I installed the one in the link, but it doesn’t work any better on my Galaxy S2 with android 2.3.6, (baseband T989UVLDH). I could have sworn it worked up until a week or two ago, so I don’t know what it would have updated to if 3.5.4 was available over four months ago. (Yes, I do automatic updates.)

I’m having the same problem as Dave, starting in the last week Newsblur does not sync. Ran fine on android 2.3.6 until then. I’m a premium customer, disappointed that I can’t run the program on my phone. Help!

Some older versions are available in the F-Droid repository. Download the client from, enable the Archive in the repository settings, and search for NewsBlur. 2.5.0 seems to work.

John, this worked great. Thanks!