Android 4.0.1 constantly crashes

Keep getting crashes with new version of Android 4.01 app. Very buggy. Unusable. Any chance this can get fixed? Thanks!

app version: 4.0.1
android version: 4.4.4
device: LGE Nexus 4
memory: normal
speed: 0 in 0

1 Like

It’s also unusably slow even when it’s not crashing. 10+ seconds to respond to clicks, 5+ minutes to sync unread articles (until which new articles are not readable at all). Would it be possible to immediately sync the feed I’d like to read, like in 3.x?

1 Like

It’s literally about 10x as slow to sync articles as previous versions were. Not exaggerating.

We’ll get this fixed next week after Thanksgiving. The app is much faster on my 2013 N7 running 4.4. But we’ll figure out what’s going on.

Please provide us with a link for the previous app version. New version is unusable for me (for the same reasons mentioned above).

I have completely uninstalled the app and after reinstalation seems ok (previously had only cleared app data). Let’s see how it goes.

Anyway, let me suggest having NB update all stories (some thousand at a time, at least for me) should be a preference. Some people have small data plans and might be better to update only on wifi.

So far 4.0.1 worked weird on my phone too. I’ve tried some things with app to see what happens and I guess I’ve found the reason of this crashes. (I’ve also reported via Google with every time it crashed with detailed descriptions like this one.)

After not being able to use Newsblur app since the upgrade, I’ve decided to delete app with all its data and re-install. I thought maybe it needs a clean installation. Purged everything on settings and downloaded it again. Everything looked normal but right after clicking sign in, it crashed without a reason and I’ve reported it.

Then I’ve started the app again and Voila! Everything looks normal, it syncs stories and doesn’t crashes for minutes. I’ve waited for app to finish sync and then tried some random feeds. Everything worked perfect, not even one crash. Then I’ve decided to change some settings for my taste. But app doesn’t wanted it.

I’ve switched background download on, changed story order to oldest to newest, read filter to unread only and switched to the dark theme. And it crashed right after the third story. I’ve reported it and tried to switch settings back to normal to see if this fixes.

First I’ve switched background download off. It crashed right after third story again. Switched back to light theme, crashed again. Changed the story order, crashed again. Reported every time (I guess, I might forgot to report one.)

Then I’ve tried something else and cleaned all data and cache to try again. It crashed at the signing in screen again. But after that everything worked normal like the first re-installation. Then I’ve decided to check back preferences again and found the real reason for me.

When I was switching back the preferences to normal, I’ve forgot to switch back one of them: Read Filter. When I’ve switched read filter to unread only, It crashed. But when I’ve switched back to all stories again, app returned normal. Then I’ve tested all other settings I’ve changed and none of them caused any trouble.

I don’t know why this is happening but the Read Filter is the reason this crashes, at least for me. It does something weird and doesn’t let us to read more than 3 stories if we switch to unread only. Right now I’ve set it to all stories and app works perfect.

Hope this will be helpful for you.

NewsBlur 4.0.1 on Cyanogenmod Android 4.4.4.
The app works fine here, but only after uninstalling/disinstalling it.
I installed it through the F-Droid repository (useful solution for those without a Google account).

I’ve similarly been experiencing untold crashes ever since the upgrade with added offline mode. (Newsblur 4.01, Samsung Galaxy S4, Android 4.4.2)

I do believe that it is to do with the read filter. If I switch the view to be All Stories, then I stop experiencing the crashes.

App is more stable but still experiencing delays or complete stops when opening feeds, due to some action being stuck (or taking too long to complete). Usually this happens with “cleaning storage” or “updating unread count”. Other operations like “updating reading actions” also seem slow.

Can you provide more information about your account size and how you use the app?

How many feeds do you have?
How many unreads do you have?
Do you view all stories/unread only for feeds?
How long is an action being stuck or taking too long to complete? e.g x seconds?
What does it mean that updating reading actions seems slow? Again, how many seconds?

Anything that would help narrow down specific conditions where the app is slow.

My environment details:

Newsblur 4.01, Samsung Galaxy S4, Android 4.4.2

1564 feeds
14,000 unread

Crashes on swiping, clicking next and navigating to the next item, or opening a new item.

Almost all crashes occur if I have I have the read filter set to unread and/or if offline mode is on. If either of those conditions are true, I can’t go more than a few minutes without a crash. Typically the crash occurs just after the article opens and displays briefly.

I submit crash reports

Have the frequency of crashes dropped with the latest update? If not keep submitting crash reports.

With about 30 min of testing, 4.0.2 appears to have resolved all issues I experienced since the 4.0 release!  Even with thousands of unread stories, the app is now highly responsive, prioritizing loading the particular feed or story I’m reading even when numerous global sync items remain.  No crashes or problems at all so far.  Very impressed and happy, thanks!!

Hmm, now seeing occasional crashes on just one large feed.

Nice to hear there have been some improvements. Please keep submitting crash reports.

Latest version seems to have fixed the issues and is much more responsive.

I have found however another strange behaviour: if I click on a story’s url to open it in the browser, when I return to NB sometimes the displayed story is the next to the one I was reading.

Showing the wrong story on return is a known issue that is being worked on.

After upgrading to 4.0.2, there are fewer crashes in general but they still occur if the read filter is set to unread.

username: koranteng

After using 4.0.2 for a few days, performance is back to being just as bad as with 4.0.1, with frequent slowdowns and crashes.