AnandTech straight up doesn't load on the iOS app

I’m not using the iOS 10 beta. I’m not using beta anything.

My workflow is the same every morning.

Open up NewsBlur on my iPhone 6s over coffee, hit all stories, and then swipe.

Whenever I swipe to a blank white screen, I know it’s because I’ve reached an AnandTech article.

Zero idea why this is happening.

Here’s their feed:

1 Like


Sigh. Bump. I ran into this issue again during lunch today.

It doesn’t happen on my iPad, but happens on my iPhone.

I mean, I love NewsBlur the best on my Mac, but I don’t want to lug this behemoth everywhere I go.

This is not specific to AnandTech but more endemic to the confused-appearing story loading process.  You can tap on the TEXT/STORY button at the bottom to get around it for now.  I think I’ve fixed it tonight ( but this definitely needs more testing and will probably have to wait until Samuel gets back.

Thank you, Nicholas. Any timeframe on when this fix will be pushed out to the App Store?

Thank you, Nicholas. Any timeframe on when this fix will be pushed out to the App Store?

My guess would be in the order of 1-2 weeks.  Samuel needs to get back from Burning Man, we need to test it and ensure particularly it doesn’t break older or newer iOS versions — I do have an iOS 10 test device myself but nothing running prior versions and we still support back to iOS 7 right now.  We might be able to push out a TestFlight beta before then, too.  Hopefully the TEXT/STORY workaround works for you for the moment!

Yep, this looks fixed. I’m hesitant to submit anything to the App Store until I get back after Labor Day. If you have the stomach for it, the code is on github and you can load it on your iPhone if you have Xcode (free).

I’m good. I’ll just hold off on using the iOS app.

Like I said earlier, I vastly prefer NewsBlur on the desktop/web, I just don’t take my laptop out of the house much since it weighs six pounds.