Why do some feeds have incorrect relative links?

Is it just me or are relative links broken in the web interface?

I’m seeing a few feeds where the links point to a 404 under newsblur.com/something rather than the specific site.

I can find an exact example if needed, but was there any changes in this area recently?

1 Like

Nothing recently, so I’d love to see some examples. Ideally in the form of their /site/<feed_id> url.

I’ll try and find one. I hit 3 earlier today, but I assumed I’d be able to find it quickly when I needed. Seems not. I’ll see what I can find. Thanks.

And these are new issues that only recently changed? I updated the feed fetchers a few days ago to use a slightly updated version of feedparser, so it’s possible but not likely that did anything.

I’ve been seeing this in the feed https://newsblur.com/site/33523/twenty-sided from address http://www.shamusyoung.com/twentysidedtale/?feed=rss2

Most recent example seems to be in what is currently the second-newest item, with title “Grand Theft Auto Trilogy: Derision Edition” - the first paragraph has a relative link right away (which I notice only has a query string):

<content:encoded><![CDATA[<p>On the podcast <a href="?p=53206">yesterday</a>,

This link gets resolved to https://newsblur.com/site/33523/twenty-sided?p=53206 when I view the post in Newsblur.

I don’t recall how long I’ve been seeing this but I think it’s been longer than a few days. I don’t think it always happened, but it’s also possible that the blog in question didn’t always use relative links.

Another example. Feed https://www.newsblur.com/site/7369348/the-motte from address https://www.reddit.com/r/TheMotte.rss

Second-newest item as of this writing, with title “Quality Contributions Report for November 2021 (1/2)”, has a lot of relative links. The seem to all start with a slash and when viewed in Newsblur get resolved relative to the newsblur.com domain instead of the reddit.com domain. For example, <a href="/r/TheMotte"> results in a link to https://www.newsblur.com/r/TheMotte.

Also, I didn’t mention this before, but in both of my examples, I’m using the website in a desktop browser, not a mobile app.

Durman writes: “I don’t recall how long I’ve been seeing this but I think it’s been longer than a few days.” Yeah. It’s been like this as long as I can remember.

I sometimes got this issue with GitHub wiki rss feed.
I think it is because it contains .. in the url link.

It will redirect to newsblur.com/<content_after_..>

I have it on my private GitHub atom feed (https://github.com/github-username.private.atom) for links in the content. The links are valid plain relative links starting with /, e.g. /Homebrew/brew, but link to https://newsblur.com/Homebrew/brew in the Newsblur UI.

This site gave me a great view of what’s happening. Looks like there is a bug and I can fix it quite easily, but the problem is that it will almost certainly have unintended consequences and I don’t want to launch that the week of Thanksgiving. I’m also finished with five months of paternity leave during the first week of December.

I’ll try to get to this then, and if you want to bump this on Tuesday, December 7th, I’ll be sure to get to it as the change isn’t hard, I just need to be able to watch how things shake out.

2 Likes

Thanks so much to everyone that got to reproducing it before I did, I got slammed and didn’t have time to dummy up some feeds.

I’ll set a reminder on this thread (yay Discourse), absolutely no rush at all.

Thanks!