WaPo National Feed misbehaving (Timestamps as stories)


#1

Starting sometime last night, my Washington Post National site (http://feeds.washingtonpost.com/rss/national) started filling up with feed items where the title is just a timestamp (example: “2018-07-26 19:33:07.635250”), there’s no content, and the URL just points back to NewsBlur.
If I open the feed URL in my browser, I see a list of actual stories, and nothing looks amiss.


#2

I subscribe to this feed too and it’s driving me up the wall. I looked into it and frankly their feed just doesn’t validate anymore.

https://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Ffeeds.washingtonpost.com%2Frss%2Fnational

I’ve reached out to them and am waiting back to hear.


#3

Appears to be better today. It still doesn’t quite pass the feed validator (and the other WaPo feeds show similar issues with duplicate GUIDs, etc), but it’s no longer creating bogus feed items in NB.

Thanks for getting this fixed, Samuel.


#4

I guess I spoke too soon. Sat down to look at my feed this afternoon, and it looks like there’s ~200 bogus feed items.

I guess I’ll be training those away until WaPo gets its act together.


#5

I run a bunch of feed ‘preprocessors’, if you’re interested I could give you a cleaned-up version.
https://tedder.me/generated_news_feeds/


#6

Just heard back, here’s what they had to say…

Hi Mr. Clay,

Thanks for taking the time to write. I checked with someone on this and he said we’re currently in the process of migrating some of our RSS feeds, which is why this might not look the way it should at the moment. Though he did mention that this current feed was loading properly on our end. Either way, please let us know if this doesn’t resolve itself shortly.

Best,
Alison


#7

Unfortunately still appears to be broken. Hope they fix it.


#8

Ok, I took it into my own hands and now if a story doesn’t have a title and any content, NewsBlur will reject it. Not retroactive, but you shouldn’t see any new WaPo stories coming in like this. Let me know if it doesn’t work as expected.


#9

Thank you!